C++ Creates a new actor and then corrupts it

Hey all, I started trying to learn C++ and started following Tom Looman’s beginner tutorial. However when I created a new actor I couldn’t access any of the functions unique to unreal, or really any of the namespaces or identifiers. I also had over 13k errors in the code, despite not having typed a single line. Any insight would be appreciated. Thank you!

Are you using the project solution set as “Development Editor” and platform as “Win64”?

After adding new class you need to :

  1. Close the editor and visual studio.
  2. Regenerate project files by right clicking .uproject file and
    choosing “Generate visual studio
  3. Open the newly generated .sln file
  4. Compile and run the code

Double check that you compile for
win64 (or for you platform) and with
development editor profile. This
options should be available for you
at the top bar inside visual studio.
Also if this does not help - delete
binaries & saved folders from project
folder and try 1-4 steps again do
not believe in intellisence error
Believe only in compile
errors, because intellisense can not
handle UE4 project size

This worked perfectly! Thank you so much, I didn’t even know what those boxes at the top were. Now I can continue my education!


This worked! Thank you so much for replying, now the learning can continue!!