Download

C++ Classes Folder isnt showing

For some reason C++ Classes Folder isnt showing up in Content Browser.
It was there the first time but it dissapeard later on in my project and now i cant get it back working.
Any clues why this could have happened?
Thankful for any help! :slight_smile:

Either you deactivated it in the content drawer, which happens, or you have a bug where the engine doesn’t recognise your C++ classes. Deleting the content of the Intermediate, vs., DerivedDataCache, Binaries (maybe also saved) folders and then regenerating visual studio project files should fix it

@HugBeg2000
Have you tried checking the View Options filter at “Show C++ Classes” ?

I have tried most of the stuff that they recomend doing, will try deleteing the files again dont think I deleted DerivedDataCache and Binaries. Will try that thx!

Update:
I deleted all the folders but it didnt do anything :frowning: , I have a Source File with all the .cpp / .h files in it but they still didnt show up in any C++ Classes Folder. Not sure what this could be, seems I might have a wierd bug hehe

Did you regenerate VS project files?

Yes, didnt do anything, its so weird, I think the only way to get it back is by redo a Project

Solution: If the C++ Classes folder isnt showing there is nothing to do except restart the project.
Somehing was corrupt with the project and I was unable to fix it, so I started over.