Download

C++ Changes not happening after compile until i restart editor

So i was curious and tried the C++ Template for an FPS, and went in and changed the speed of the projectile in code, pressed the compile button in the UnrealEd and nothing happened. after i restarted the editor the code worked properly.

While it’s not pressing, one of the biggest advantages i saw to UE4 was that it was possible to change & compile in C++ without restarting the engine. So I wasn’t sure if it wasn’t implemented yet or i’m doing something wrong?

For those curious:

  • I saved the file before compilation
  • Using MSVS 2013 Premium
  • Standard UE4 (not source code version)

Haven’t changed anything else, Any Tips would be nice, If it’s not yet implemented i understand (i just wasn’t sure if i was doing things wrong or not), Thanks in advance!

I am also experiencing this, same details. It does successfully detect errors, but it seems to not actually change variables in the editor’s view if it builds successfully(At least, that is how I see it as a layman).

I believe those links might be of use:
https://answers.unrealengine.com/questions/15350/compile-in-editor-doesnt-apply-code-changes.html
https://answers.unrealengine.com/questions/17558/make-changes-to-code-without-restarting-editor.html