C++ Build fails error code: -1073741571

Hey all,

I added a Util header file and C++ file to my project in VS then decided to remove it. I went through the files that made reference to it (the Character header and C++ files) removed the includes, and any of the code that made reference to anything in the now-gone util file and now the project won’t build with the following errors:

Info Parsing headers for [redacted]
Info Error: Failed to generate code for [redacted]- error code: -1073741571
Info UnrealHeaderTool failed for target ‘[redacted]’ (platform: Win64, module info: D:\Unreal Projects[redacted]\Intermediate\Build\Win64[redacted]\Development\UnrealHeaderTool.manifest).

Does anyone have any ideas of how to fix this? The code itself is sound. Visual Studio doesn’t see any actual issues with it so it should compile perfectly. A quick Google search seems to indicate the build order may be out of order for the linker?

Here’s the odd bit that I can’t figure out: The code I committed to the repository on Friday is identical to this code now (it has none of the references to this now-removed Util code I wrote and it compiles/builds/runs). I’m at a complete loss here.

I even went so far as to manually correct the differences between this latest version I have locally with the current version in the repository and it still doesn’t build.

~~ Nate

I’ve since been able to pull an earlier version from the repository that worked. I have no idea what caused the problem but I suspect it was something to do with Visual Studio. It would get to the step where it would start parsing the header files and fail immediately with the above error.

The odd bit is the only difference between the build version from Friday versus the current build is the header files were never included in Friday’s build nor were their functions and constructors. Very weird.

Marking as Resolved. Hope no one else has this problem.