Download

C++ 4.14 Transition Guide

Hi all,

An easy one, but just in case :slight_smile:

UWorld::GameState is now private, so


GetWorld()->GameState

will give you an error:


Error	C2248	'UWorld::GameState': cannot access private member declared in class 'UWorld'

You can now use


GetWorld()->GetGameState()

instead.

Cheers
Cedric


UPROPERTY()
TArray<FName> AnimationTrackNames;

in UAnimSequence is protected now

If you protect something, Epic, then please give us a method to get the property.
This prevents me from updating my animation tools to 4.14.

If a plugin inside the project(Inside project folder) is enabled and I play the game in standalone, it crashes upon pressing any key.

Is not solved yet?

Hi,

It’s not a standard “transition” question with build issue but more with process changes:

Does that means that the cook content can be shared accross platform as per this trello card: Trello ?

I can’t have any anwser on the official thread, so I hope someone here is able to answer / confirm this.
This will clearly help in the cooking process if I have only 1 content cook for all platforms.

Thanks!

That would be great if that were so, would make patches across multiple platforms a lot easier :slight_smile:

Rama

I hope someone @epic will anwser us on this. This is a time saver for everyone that start distributing their game ^^

Our project won’t load under 4.14 a pop-up error box is shown -> “The game module ‘blahblah’ could not be loaded. There may be an operating system error or the module may not be properly set up.”
Some moments later later there is a crash in the destructor of UNavigation() and the output of “Illegal call to StaticFindObject() while collecting garbage!”
I’m not convinced the crash is the problem, more like a side-effect.

Anybody have any ideas of what the problem is or a tried and true approach to debug this? Thanks.

  • David

By a process of elimination, if I disable our Wwise plugin we can load OK… The Wwise plugin works in a 4.14 ‘toy’ project but not in our project. I’m suspecting something in our blueprints specifically in our game.

It kinda looks that GetBodyInstance() got changed too? Im trying to use the TraceComponent function and it works unreliably

This is my result in 4.14 just by using draw debug line

And this is the result of the actual hit locations

Every other trace function works fine except trace component

Like DavidGalloway, while loading the project I get “The game module ‘blahblah’ could not be loaded. There may be an operating system error or the module may not be properly set up.”
With debug I found that the problem is that the windows api function LoadLibraryW fails to load the project dlls (I have two modules and both dlls fail), so I guess something is wrong with their compilation, but I don’t know what to try now.

DavidGalloway and matfer, I had a similar problem, though I am running on Linux. I think the error message that the editor displayed in a pop up was similar to what you have both written, but the message was not saved in the logs as such.

Here’s the what I did find in the logs:

LogLinux:Warning: dlopen failed: /path/to/project/Binaries/Linux/libUE4Editor-project.so: symbol _ZThn1064_NK5APawn24GetNavAgentPropertiesRefEv, version UE4 not defined in file libUE4Editor-Engine.so with link time reference
LogModuleManager:Warning: ModuleManager: Unable to load module ‘/path/to/project/Binaries/Linux/libUE4Editor-project.so’ because the file couldn’t be loaded by the OS

I resolved it by renaming /path/to/project/Binaries/Linux/libUE4Editor-project.so (I did not want to delete it in case it was the wrong thing to do) and restarted the editor for the project in question. The editor asked me if I wanted to build the missing .so which I let it do and that fixed it.

If this is the same problem you are seeing, I expect you’ll find the relevant .dll under /path/to/project/Binaries/Win64/libUE4Editor-project.dll. Try renaming that and restarting the editor (probably best to not be in the editor when you rename that dll).

I am also trying to port a custom IK node, and am running into linker issues for FAnimNodeEditMode. Would you mind sharing your included modules?

Errr… Getting this weird error from 4.14:

“fatal error C1083: Cannot open include file: ‘ObjectBase.h’: No such file or directory.”

Am I missing something from the engine?

My problem seemed due to project plugins not being compiled or loaded, and I solved enabling all my project plugins in the .uproject. Maybe older versions used all project plugins by default, while 4.14 needs them to be enabled explicitly.

Lots of people who got hit by Navigation changes here, but none who had problems with the changes in inheritance?

https://answers.unrealengine.com/questions/531791/how-do-i-work-with-vehicle-navigation-in-414.html

I can most likely solve it by taking UWheeledVehicleMovementComponent and above into my own project and parent it to UPawnMovementComponent myself.
But it would be nice to know if it was an intended change and they want to do navigation differently or if it’s a bug that they will fix.

Does anyone know?

I’m also seeing the ObjectBase.h error with a plugin. Any luck with this @KillerPenguin?

Sorry, haven’t really investigate anything with object.h. We reverted back to 4.13 for now.

I have done something very similar but having problems linking the methods in FAnimNodeEditMode (referenced in my derived class in my own plugin).
e.g.
error LNK2001: unresolved external symbol "public: virtual bool __cdecl FAnimNodeEditMode::SetWidgetMode

I don’t have any issues with the associated UAnimGraphNode_SkeletalControlBase derived class, even though this UAnimGraphNode_SkeletalControlBase is in the same module as FAnimNodeEditMode.

Did you encounter any problems like this and/or do you have any idea where I’m going wrong?

  • Ben

what’s going on with C++ widgetcomponents? If i subclass it I get a bunch of FWidgetandPointer errors. Thanks

After further investigation, it seems that FAnimNodeEditMode is not exported. I’m not sure if this is by design or an oversight, but the workaround we used was inheriting from IAnimNodeEditMode instead and copying whatever functionality was needed from FAnimNodeEditMode into our new class.