Buttons Stop working on Standalone Build

The Issue : The buttons I have set up for my main menu will simply stop working in the ‘Standalone Game’ instance. They don’t highlight once hovered over, and they as well are completely unresponsive to button presses.

However, the buttons work in the Play in Editor and torn off window, so still technically part of the editor itself.

Here’s a screenshot of the Standalone Editor, the mouse cursor isn’t visible, however it was hovering over one of the buttons

Here’s a screenshot of the torn off window that is still part of the editor, I messed up with the hover color, so its not very visible, however if you look closely this instance will actually use the hover and the buttons are clickable and will advance to the next menus.

Here’s a sample of the code that specifically relates to showing the main menu and enabling the mouse cursor.

Just to prove that this is getting called, this is stuck in the Main menu’s level blueprint.

[All of this code was based off of the Multiplayer tutorials][4]

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/widgets/settings that may be involved with this issue?

Yes, I went ahead and replicated the problem in a clean project last night. I didn’t touch anything in that project related to the default settings with player controllers or such.

I just put a button in the default blueprint project and added it roughly the same way I’m going through with my project. (Screenshots don’t seem to grab the mouse cursor, but I did set the highlighted color to be red, and had the mouse cursor hovering over the button).

Here’s the blueprints related to the clean project and adding the button.

This is just about the exact same way I added the other buttons in my main project. The biggest difference is that I’m cutting out the middle man functions used in the project that are accessed via casting to that component.

Just to be thorough, here’s where I got access to my game instance class that creates the Main Menu widgets, this is on the MainMenu level blueprint.

After reviewing my initial post, I was incorrect slightly, both of those code snippets are in my GameInstance class, the third screenshot in this reply post is the level blueprint code that is being called, but the Save Game Check itself is being called from the level blueprint.

[first two screenshots are from the clean project, and the third is from the original project]

Sorry, I didn’t provide a detailed list of steps, since I replicated the problem in the secondary clean project with all the blueprint code that is listed as all the code that is in the project. So the steps taken for that were

  1. Create project
  2. Create button widget
  3. Change highlight color to red
  4. Create the code listed in the blueprint that shows the widget.

One funny thing that happened in the secondary project, if I alt-tabbed while hovering over the button, it would highlight to the red color that I’d selected it to highlight to. So I’m guessing that Unreal is having trouble recognizing the mouse.

I began to replicate my interpretation of what’s going on with Kyle’s situation, using 4.14.0. I seem to be having the precise same problem, but multiplayer/networking is irrelevant in my situation.

If I Play a Standalone version of my build, my UI will not work (similar to Kyle’s situation above). When running everything in the editor via Play, however, it all acts as expected. (AKA, it works well).

There’s something about trying to Play a Standalone version that’s changing how the UI is acting. Maybe there is a setting somewhere that both Kyle and I are missing?

After some more research through the Answers around here, I discovered the BP node “Set Input Mode Game Only” - I put this at the beginning of my logic. This -might- have solved my issues. Kyle, try that and report back.

This solution ended up working some of the time, but we used the “Set input mode Game and UI” and that has worked so far.