Download

building UE4 from source.

I am following the directions have gotten to the point of downloading it onto my computer and clicking on the 2 files setup and the get files one(forgot name). I did those successfully. The next step is for me to double click UE4.sln to start it in Visual Studios.

Here is the problem: there is no UE4.sln. I did a search too nothing. am i doing something wrong. I personally looked thru all the source and all the folders and sub folders, NOTHING.

any suggestions on what im doing wrong?

GenerateProjectFiles.bat makes UE4.sln for You.
You ofc should have VS installed.

yeah i used that file it did its job but still cant find UE4.sln I will run it again

yeah i ran both setup.bat and generateprojectfiles.bat . it didnt make the UE4.sln for me.

It does not generate the UE4.sln for me either, I’ve uninstalled and reinstalled both the source, and VS, double checking to make sure that all components are installed and it still is not generating.

I just figured it out, I also had VS 2015 installed, uninstall that, then intsall http://landinghub.visualstudio.com/visual-cpp-build-tools and it worked perfectly.

This works for me, thank you!