"Building navigation" all the time when I move something

How can I stop this madness? Everytime i change the heightmap or move a mesh or a BSP brush, it is building navigation again. It’s impossible to work this way.

All options that should disable it don’t seem to have an effect.

Well, everytime you move something, navigation does have to rebuild. I remember (a while ago) reading (or watching) a tutorial about runtime navigation. You might want to search for this if it’s really getting to you.

I don’t understand how anyone can work this way, if every move you make starts the building process that makes everything slow and stuttery - so everything is always slow.
I changed the runtime options in the navigation mesh project settings. But it doesn’t seem do have an effect, I dunno.

just delete the NavMesh Volume and add it back when you’re done with geometry

1 Like

Good idea! I didn’t delete it but moved it far Z up and it worked

3 Likes

I know this is late but in case if someone is still having this problem, you can disable the navigation updates in the editor → Open Edit->Editor Preferences-> LevelEditor (Miscellaneous) and set “UpdateNavigationAutomatically” to false

7 Likes

And that somebody was me, thanks!

After doing this, when does the NavMesh rebuild?

You either build it manually or just set UpdateNavigationAutomatically to true after you finish your updates

I have packed it into a DataLayer and can now activate it when I am finished