Download

Building Linux or LinuxServer DLC (PAK) on Windows stopped working in 4.27

Hello, has anyone encountered that in 4.27 you cannot build for Linux or LinuxServer PAK files? I can build the LinuxServer just fine, just not normal Linux platform. I also cannot package DLC (.PAK files) for my Linux Server anymore.

I am setting up a VM with Fedora to try there, but this has always worked. Anyway I can change it back to work again? Starting to use 2 PC and compile in 2 places is not the move!!

PAK Files for Linux Server is HUGE for my project, as the way maps are made are designed to all be hotloaded with .PAK files, given there can be way too many to ship with the game. In fact my game is just a menu, and every world is downloaded individually, so when a server starts with that world, it downloads the appropriate world and servertravels everyone there. Now I can’t build LinuxServer PAKs on Windows in 4.27. This worked in 4.26, I upgraded my project and kept working, and had no idea such a niche feature would disappear.

Please, and thank you!

-Brandon