Download

Building from Source error (ARCore)

Hey all

So, i downloaded the .zip folder from Github for UE4 with the ARCore from here https://github.com/google-ar-unreal/UnrealEngine/tree/4.17-arcore-sdk-preview
Following the “Readme” guide in the download, i can get to the “Right click and build” step on the UE4 within Visual Studio and i get a bunch of errors.
I am a complete noob when it comes to building from source and using GitHub so i apologise in advance xD
I have downloaded Visual Studio 17 (v 15.4) and included the necessary workloads (desktop development with .NET, Desktop Development with C++ and Game development with C++)
When i build in VS i get 15 warnings as the image attached.
I am running this on an alienware laptop with Windows 10, i have Avast Free version but had it turned off when doing the build.

I would really appreciate some help on this.

Thanks

In the Visual Studio Installer, go to the ‘Individual components’ tab, there at the least I checked ‘.NET Framework 4.5 targeting pack’, and under “Compilers, build tools, and runtimes” i checked ‘C++/CLI support’. I’ve attached a pic of some of my settings. You may have to also separately search and download the latest MS Visual Studio redistributable. Also I tried Cleaning the UE4.sln and building again.

Although, you may not have to do this anymore since they just released 4.18, I haven’t tried it out yet thought.