Building bares little resemblance to editor

Hi guys,
I’ve made a project with mouse/VR support - in the screen shot you can see version mouse on the left with a crosshair, in VR mode in the middle you get the controller. Both work as expected when previewing out of the editor. The blueprints detect an active HMD and give you mouse mode if it isn’t active.

The 3rd screen shows what it’s like once packaged - all the textures are super blurry, and NO INPUT works, neither HMD or mouse input.

Has anyone got any idea what I’m doing wrong? Any help much appreciated.

When exporting to Oculus Go it works fine in the headset.
First issue is why wouldn’t any of the high res textures show? and why is input not enabled? is it actually crashed/hung as soon as it starts? or is the app running but not sure what to do? How can I find that out in the first instance?

Please help, someone, this is the first time I’ve tried actually building anything and I expected the build to be like the editor…

Hmm, seems my issue is with my platform selection method - when I fixed it to only allow through ‘Windows / no HMD’ it seems to work OK… how do people normally handle multiple platform/input method support in a single game?