Building a demo level

Maybe this is a bit of a newbie question, but I’ve been building a level according to the tutorial videos and would now like to build them. However, if I build the game, it gives me the standard first level and not the level that I have created. I’m quite sure the solution is between the screen and the chair :slight_smile: So could you please help me out, because I haven’t seen a tutorial or a help covering this issue and I really don’t need a full game right now, just one level to give it to our hardware testers. If there is some study material considering this, I would be grateful if you pointed it out for me. Or if there is an easy 1-2-3 solution that I have missed?

kind regards

Take a look at this thread: https://answers.unrealengine/questions/36373/package-one-from-shooter.html :slight_smile:

thanks for the info! however likely the problem is somewhere else - is there perhaps a tutorial or a video as to how I should build the project?
I still only seem to get the default level - when I use “build” it makes the game in my unreal folder, when I package, it puts it in my chosen folder, however the only executable I find still only has the blue-white default level and not the level I built (though in the project settings i’ve chosen my own level to be the default level). I must be doing something wrong, what would be the correct workflow when building the game into an executable?

Have you clicked onto “set as default” after you have added it? Because for me it works ^^

My steps:

  1. created the map and saved it into the content olfer
  2. Project Settings - Maps&Modes - at Default Maps I added my map (to both, so game default map and editor startup map)
  3. file - package project - shipping - windows
  4. now it should have created a folder and there under “ProjectName” - Binaries - Win32/64 you should fine a .exe

thanks, you’re a lifesaver :slight_smile: “set as default” did the trick!

That crucial click is a major “gotcha” for a lot of people it seems, myself included at first. The label on that button should probably be changed to something else, like “Apply settings to this project” or something like that, to make it clear why it’s important.