Build-System ignores updated static lib

  1. Link a static library to your project
  2. Rebuild the static lib
  3. Rebuild the Unreal project
  4. UBT uses the old version in cache instead of the new static lib

XCode 7.3.1 on OSX 10.11.4

How would I force the Unreal Build Tool to use my latest static lib?
We need the UBT to be more customizable, I think in 4.13 something like this was added, but there is no documentation. There are a lot of problems and glitches when building on OSX, I think we can save a lot of time on both sides, (fewer questions, fewer answers needed) when the UBT comes customizable. :slight_smile:

Thank you for your time.

Hi rotwang,

Thank you for bringing this to our attention. I was able to confirm the issue that you described does occur in projects being worked on with Macs. With projects on Windows the new static library was used. I have entered ticket UE-35801 to have this investigated further.

Funny. The more I dig into UE4 the more I don’t like it due to these simple errors everywhere.

I have exactly the same problem, spend another 4 hours on this.

Dear EPIC, such basic things are very important and normally should be tested by unit testing, if you have such critical issue in the release you should remove it from Stable and let developers use older/working versions as this can’t be marked as Stable!

By the way, this issue is still not fixed on:
UE 4.14.0, MacOS Sierra 10.12.1, Xcode 8.1

“I think we can save a lot of time on both sides”… ■■■■ true…