Build not working

“Sorry for the spam, paying money to use this engine and I have not had a response in over 24 hours.” - Such Tartiness.

Hello, I am new to Unreal Engine 4.

(Win7 64bit, UE4.2)

I have attempted my first build (local) & cannot get past this error.

  1. Click “Build”

  2. Build Status opens, “Starting up Swarm Connection… (100%)”

  3. Open Swarm Agent

  4. This is what I get.

Starting up SwarmAgent …

… registering SwarmAgent with remoting service

… registering SwarmAgent network channels

[ERROR] Channel already registered, suggesting another SwarmAgent or client is running.

[ERROR] If you feel this is in error, check your running process list for additional copies of

[ERROR] Sleeping for a few seconds and trying again…

My Firewall is turned off, Ran it as administrator, searched through dozens of threads and have not found a solution.

Thanks for taking a look into this report.

Hi there, can you please verify that there are no other instances of SwarmAgent running? If you have an icon like this in your system tray:


Then please try closing it and trying to build again. Also, you could have a look in the processes view of Task Manager (Press CTRL+SHIFT+Esc) and verify that there are no processes with an image name of “SwarmAgent.exe”. If there are, end them and try again. Let us know if any of these work, and if not we can explore some other avenues.

You haven’t had a response in 24 hours because you posted your original threads on a Sunday. It often takes a few days to get a response due to the volume of requests, but you’re unlikely to get an official response on a weekend.

That’s good.

Hi Andrew thanks for the response.

There is only one SwarmAgent running after clicking build, ending its process does not unfreeze the unreal engine & would also have to be closed, reloading the engine and building repeats the process.

My mistake for not including the fact that the engine becomes unresponsive.

The process goes, I click build and it pops up with the connecting to swarm (100%) with an orange progress bar, I cannot press stop build or anything else, however; in the task manager the engine is fine and does not say non-responsive.

The swarm agent when opened manually gives the same error as first mentioned.

In the task bar when double clicked, reads the same error, the Swarm status, is empty, Log is logging the errors.

It is strange, SwarmAgent is not listed in Listening Ports.

Indeed, while it is being run. Also the port 8008 is not listed in the Listening Ports.

Just to be clear, is the engine freezing and locking up, crashing, or none of the above? Your original question seemed to hint that it was just a problem connecting to swarm for some reason.

Another thing to try would be to manually start up swarm yourself before hitting build. The executable itself is located inside Engine/Binaries/DotNET/SwarmAgent.exe.

Also, if you double click the SwarmAgent icon in the taskbar, is there any activity in the swarm status tab?

Thanks for the extra info, Klubnika.
I suspect there’s something on your machine that is bound to the same port that SwarmAgent requires. Could you open up task manager, then click Performance Tab->Resource Monitor->Network Tab->Listening Ports.

This should show you a list of ports that are in use on your machine. According to my machine, SwarmAgent is using TCP port 8008. Could you check that you have no other applications running which are using this port, and whether SwarmAgent is managing to listen on this port?

Even when the process is running? That definitely seems like something else is hogging that port then. Are there definitely no other processes listening on 8008?

Hmm, this is getting difficult to assess! Could you have a look down this list and see if anything could be using the port? You don’t do any web development or anything like that do you? Port 8008 (tcp/udp) :: SpeedGuide

Could you also check there are no rogue UnrealLightmass processes please?

Excuse me, Resolved? Where was this resolved, on some magical computer that is not mine? Because I still cannot build, Swarm Agent is not working and the matter has 100% NOT been resolved!!!

Sure no problem, there are no rogue unreal apps running, tested after system restart to make sure.

The port 8008 is not used anywhere on the network. I do not do any web development.

That is fine, it really is not an inconvenience when there is help looking into this, which is very much appreciated. Thanks again.

Sorry about that, I submitted a comment half an hour ago that somehow ended up in moderation which magically marked the issue as resolved!

Ok, thanks for your patience. I’m forwarding this issue to a wider audience internally so we can try and get this sorted for you, sorry for the inconvenience.

Unfortunately none of these options have worked, I tried them earlier, firewalls are turned off including my antivirus. I have tried running Swarm Agent as admin and set all other Unreal related exe’s to run as admin.

I do not know what Swarm Cluster is and have not seen it being used yet.

Here is the log file. I had to zip the notepad file.

link text

I have a few more things to check. Could you try turning your any anti-virus software off and see if that helps? Also, I know you tried running it UE4 as administrator, but could you try running your own SwarmAgent as administrator as well to ensure that it can have the correct privilege? If neither of those things work could you upload your agent log from the swam agent.

Also just to check, you’re not attempting to use a swarm cluster at this point are you? Just a simple agent locally on your machine?

Did not see this comment, thanks for clearing that up. The second I responded to it with a new thread I noticed you removed the resolved state, and thought I was going crazy & imagined it, haha. Thanks again.