Build not running on Gear VR (but runs in cardboard)

Having some experience with normal cardboard, I’ve switched to gear VR, and immedeately was stuck.
My build (Oculus and GearVR plugins, ossig and all, building for ES 2 or ES3.1, 24, ASTC) won’t run in normal Gear VR mode on Galaxy S7. It’s perpetually stuck in black screen, and displays a message saying I need to install Google VR services (Google VR plugin disabled in the project), so I installed it. Still nothing.
Only by enabling a developer mode in GearVR I was able to start my app. As a normal cardboard(without google plugin!). It runs smoothly, everything is working ok, but that’s not what I want. I want gear VR! With correct position of the lenses, and all.
And I can’t really find anything useful on this matter. Everything is really outdated and I’m following all the directions I was able to find. Rebuilding with other compression settings gives nothing.
Logcat is attached. Can’t really comprehend what to look at here, so… link text
And while we are at it - is there any way to have blueprint access to “close” and “options” buttons on cardboard, or it’s okay to just override them with touch input with corresponding coordinates?
Thanks in advance for any thought on this!

Are you sure you disabled both Google VR plugins? You probably still have the controller one activated? They need to be both disabled and the engine/project must be restarted afterwards. (Also be sure to have configure gearvr manifest ticked )

Thanks for the answer! Sorry, but Google VR is disabled, and Transition 2D too. Other Google VR plugins I’m not seeing. Tried to switch Simple HMD on and off too, but nothing came from it.
Confugure for GearVR is ticked too.

What about the Google Controller plugin? It also needs to be disabled and is not located in the VR section. And just to make sure you are actually plugging it into a gear VR device right?

hmmm. Nope, disabled by default. Google VR Motion Controller? Nothing else come up with “google” search. Plugging it right? I’m launching the app, it prompts me to insert into gear VR. I’m plugging it in, and it just shows me black screen with a little close button in the corner. And it’s not keeping screen on for long, it blocks screen like it does when nothing is running. I’m pressing unlock button, and it’s still the same black screen. Goes on forever (far longer than it takes when launching as cardboard anyway).

Ah seems I misunderstood your problem (I thought you were still seeing the Google UI)

It could be building for Android 24? Gearvr should be 19 min and 21 target I think

(You could also try building with ETC2 to see if that is the cause)

Ah, okay. Sorry, I’m out of reach of my stuff right now, I’ll report back in a couple of days. I’ll keep on tweaking, and try to set it to 19-21 first thing. ETC2 already tried, didn’t work. Thank you for your patience.

It worked! Thanks a lot! Too bad Es3 and Vulkan features are still unavailable in Gear VR. Hope it’ll be updated sooner or later.