Build Failing


So i was creating a small project just so i can teach myself the basics of ue4, im currently trying to build the project to test the scalability settings code i created however, it says i do not have a correct compiler installed, is this refering to my code or something, also if there is any information you require please let me know :slight_smile:

Howdy Fortune Studios,

I am going to need a bit more information before I begin digging into this issue. What version of UE4 would you be using when attempting to build this project and is your version of UE4 binary (launcher) or Source (GitHub)? Also, would you be able to attach your DXdiag to this post? What version of Visual Studio would you be using?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Hey, I am running the 4.x version(sorry cant remember the exact number but its the most recent in the 4.x version) i am using the binary version. I have the directx 11 SDK installed if that has anything to do with it, here is my dxdiag, thanks! link text

There have been a couple of other user with a similar issue and they have had it solved by getting Visual Studio 2013 Express. Is this the program that you are using when trying to compile your project?

Yes, I am running Visual Studio express. There was an update but i figured as the 4.5 release came before the update it wouldn’t be the cause, i will try the update now and update you :slight_smile:

@Sean Gribbin The update seemed to have worked, thank you:)

@sean gribbin Hey, so it was working last night however today when i was trying to build,i got this error
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: You are attempting to compile on a machine that does not have a supported compiler!
im not everything is pretty much the same :confused: any ideas what else it could be?

Hey FortuneStudios,

Would you be able to attach your project log files to this post so that I can further investigate?


Hey sean,

Here are my log files: link text

thank you!

sorry i just realized i said 4.x, i mean 4.4.x is the version im running on :confused: sorry for any confusion that may have caused

Would you happen to have an AntiVirus program running on your computer at the time of Packaging?

I also found another user that had a similar error here: Program.Main: ERROR: You are attempting to compile on a machine that does not have a supported compiler! - Platform & Builds - Unreal Engine Forums

Please let me know if any of this helps with your issue.

Hey mate,

i tried verifying that didn’t work, however i uninstalled comodo antivirus and it worked straight away. Thanks for the help :slight_smile:

Hey Fortune Studios,

Glad to hear that the issue has been resolved. If you run across a similar error in the future, Please feel free to re-open this issue so it can be further investigated.

Thanks and have a great day!