Build failed windows

Don’t now why it won’t build :confused: Someone can help me ?
Thanks a lot !
link text

Hello aubertaxel,

Thank you for providing the log, that is very helpful for diagnosing your issue.

The main problem that I see is this one:

MainFrameActions: Packaging (Windows (64-bit)): WindowsPlatform.get_Compiler: WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that “Common Tools for Visual C++ 2015” was selected when installing Visual Studio 2015.

This means that there is a part of Visual Studio that you’re missing that is required for C++ projects. You can fix this by going to your Control Panel > Programs & Features > Microsoft Visual Studio 2015 and selecting “Change”. This should bring up the Visual Studio 2015 setup. If prompted for an update, you can hit Skip for now. After that, you should have the option for “Modify”. Select this and then find “Visual C++” under “Programming Languages”. Check this option and then hit next. Once it finishes, the correct module should be installed.

This should fix the problem but there is another thing that I see that is a bit worrying:

MapCheck:Warning: Warning look StaticMeshComponent /Game/Untitled.Untitled:PersistentLevel.LookAt_2.look : Externally referenced

There are quite a few of these for different assets. “Externally Referenced” is usually something that happens to assets when a project is converted to a new version of the engine. This can cause them to be unable to be saved sometimes which would cause problems when packaging. If you still have those problems and they stop you from packaging, please let me know and we can look into fixing that.

You are my hero of the day, thank you very much!

Thanks a lot !

Hi Matthew, your solution Visual Studio did bring me a lot of clarity. The packaging takes a lot longer now, but despite I did what you said it keeps failing. Do you mind looking at my log? It would be much appreciated

Hello dreetjem,

Your errors seem to be quite a bit different than the ones in aubertaxel’s logs. If you would like further assistance with this issue, please create a question specifically for your problem. I’ll watch your profile and pick it up whenever you create it. Be sure to include the log file there as well so that all of the information is in one place.