Build failed development target not found

I have been trying to get a dedicated server up and running using these instructions

However I am getting an error in the unreal frontend while in the “deploying content” stage

Heres the log:

BuildCommand.Execute: ERROR: BUILD FAILED
Program.Main: ERROR: AutomationTool terminated with exception:
Program.Main: ERROR: Exception in AutomationScripts.Automation: Missing receipt 'UE4Server-Win64-Development.target.xml'. Check that this target has been built.
Stacktrace:    bei Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:Zeile 1447.
   bei Project.CopyBuildToStagingDirectory(ProjectParams Params) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:Zeile 1535.
   bei BuildCookRun.DoBuildCookRun(ProjectParams Params) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Scripts\BuildCookRun.Automation.cs:Zeile 211.
   bei BuildCommand.Execute() in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\BuildCommand.cs:Zeile 37.
   bei AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Automation.cs:Zeile 380.
   bei AutomationTool.Automation.Process(String[] CommandLine) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Automation.cs:Zeile 352.
   bei AutomationTool.Program.MainProc(Object Param) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Program.cs:Zeile 172.
   bei AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param) in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Utils.cs:Zeile 716.
   bei AutomationTool.Program.Main() in f:\UE4 Source GIT\UnrealEngine\Engine\Source\Programs\AutomationTool\Program.cs:Zeile 119.

Program.Main: ERROR: Missing receipt 'UE4Server-Win64-Development.target.xml'. Check that this target has been built.

ProcessManager.KillAll: Trying to kill 0 spawned processes.

Program.Main: AutomationTool exiting with ExitCode=1

Domain_ProcessExit

ProcessManager.KillAll: Trying to kill 0 spawned processes.

AutomationToolLauncher exiting with ExitCode=1

copying UAT log files...

RunUAT.bat ERROR: AutomationTool was unable to run successfully.

I already tried deleting baseengine.ini but it didnt work, I appreciate any help!

I’m having the same issue above trying to follow those steps and getting that error. Just tried with the engine source built from the 4.9 release tag.

This really shouldn’t be so complicated, can someone streamline this process? There appears to be multiple ways to accomplish building the server all of which involve some ‘magic’ that the instructions leave out.

EDIT: I had to regenerate my visual studio solution files. That step was skipped as adding C++ classes in step 4 of the guide didn’t mention regenerating those (this answer did however). https://answers.unrealengine.com/questions/180903/issue-when-building-dedicated-server.html