Build Fail Troubleshooting Output Log

I’ve been trying to package to Android for a month now. I’ve been fixing one error after another but now I’m stuck. I need help on how to use the Output log to troubleshoot. There are a couple of warnings at the start of the packaging process which I’m not sure is the cause. Log File Attached. The first error starts during the PERFORMING FINAL APK PACKAGE OPERATION (D:\Documents\Unreal Projects\Element_Battle_Betha\Intermediate\Android\APK\build.xml:29: java.lang.IllegalArgumentException: Malformed \uxxxx encoding.). I believe that the error is specified here. (at but I cant find where this is referenced from. I have already reinstalled everything. I have Also installed Java 7 and the latest ANT. I have download all the API versions and have tried various ones with either Android (ETC1 or ALL) selected.
Any suggestions would be greatly appreciated.

Hi Slither1701,

The problem appears to be Apache Ant, you’re getting the error you linked and also ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c “D:/NVPACK/apache-ant-1.9.5/bin/ant.bat” -quiet release

Unfortunately, there’s many variables that can cause that. Are you running the Android SDK or TADP (now AndroidWorks)? If it’s the former, you might consider using AndroidWorks, it is better integrated with use for UE4. Also, this won’t cause your package to fail, but I see you have your SDK API level set to ‘android-22’. You should set this to ‘android-19’ to be able to run your project on anything less than Android OS 5.

When you’ve checked that out, here is anAnswerHub thread with many suggestions as to what can cause the ant.bat failure. My advice is, use the Tappy Chicken project from the Learn tab of the launcher as a test project to use when you’re setting up your SDK for the first time. It is optimized for use with mobile, and testing with it will rule out any possible project specific problems.

Is it possible you have some unicode characters somewhere? This usually means it wasn’t able to parse an international character properly.

Thanks Wittleif. I did have AndroidWorks at first but changed to the TADP one after the error. I also did use android-19, have tried Java 7 and 8. I had the previous version of Ant as well. I’ll change back to AndroidWorks and give Tappy chicken a try.

Thanks Chris. From all my troubleshooting that appears to be the problem. Although I cannot locate it. Build.xml:29 calls But there is no unicode in that file. The only thing I could come up with is that it might not be locating the file due to a possible fault in source.dir. So I changed build.xml but the changes don’t stick. I understand I must use the android tool to change it, but I don’t know where this tool is. Gonna try the AndroidWorks and Tappy chincken then will respond.

Thanks Wittlief. The unicode error was caused because I had the project name in brackets. Removing the brackets got rid of the “java.lang.IllegalArgumentException: Malformed \uxxxx encoding” error. I’m still getting “ant.bat -quiet release” so will be focusing on that.

Got it working :D. But not sure about the solution. As long as it works right? :slight_smile:
After it worked in Tappy chicken I checked for differences and the only two, one was the location of the keystore file (although) I don’t think this was the problem. Mine was in users*user\ directory. I changed it to *project\build\android directory.
The other difference was “package data inside APK” which I did not have set.