Build error while packaging in 4.12

When every I try packaging a project I get this error:

MainFrameActions: Packaging (Windows (64-bit)): at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
MainFrameActions: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute()
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] CommandLine)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
MainFrameActions: Packaging (Windows (64-bit)): Domain_ProcessExit
MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files…
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

I have Visual Studio installed… How can I fix this? I tried it in 4.11 before 4.12 was released and still had the same problem.

Attached is a text file of the log…
link text
Here is a screen shot of the packaging settings: http://i.imgur.com/RaCBN77.png

Here is a screenshot of my dxdiag: http://i.imgur.com/plVjOe4.png

Hi kidarole1203.

Is that the entire log? If not please cut and paste the contents of the entire package log into a text doc and attach here. Also please post a copy of your dxdiag as well as an image shot of your packaging settings in Project Settings.

Thanks,

Steve H.

Hi kidarole1203,

Since we have not heard back from you in a while, we are marking this post “resolved” for tracking purposes. However, if you continue to get build errors when packaging in UE4.12, please respond with the requested information and we will continue to investigate the issue.

-Steve H.

I added the full log and screenshots of the Project Settings and the dxdiag.

A few things to check/try:

  1. Make sure you downloaded and installed Common Tools for Visual C++ when you installed Visual Studio
  2. In your package settings, check “Full Rebuild” and “Include Debug Files”
  3. Set Staging Directory as a desktop folder temporarily
  4. Post Debug files from Staging Directory if fails again
  5. Try to Package: Third Person Blueprint project (this is a simple project that packages easily in most cases)
  6. What device are you packaging for? ie. Windows 32, 64, Android etc…?

I tried all your ideas and here’s what I got:

  1. I downloaded and updated everything and that did not fix the problem.
  2. I tried this and still, the same problem. (I don’t know how that would’ve fixed it anyways since I’m not too familiar with Unreal Engine)
  3. I tried that and nothing new.
  4. What Debug files?? No files are created during the build at this point.
  5. The Third Person Blueprint actually worked. But like before with the other templates (Advanced Vehicle Template, First person, and a scratch project still didn’t work.
  6. I tried for Windows 64x and Android and both had no difference in the error.

So if the Third Person worked, what could be wrong with the others?

Thanks for the information, I need to collect a little more information:

  1. Are you using UE4.12 from the Launcher or from source from Github?
  2. Are the templates you are testing C++ projects or Blueprint Projects?
  3. Do you have Visual Studio 2015 (vs 2013) installed; this is required to compile C++ projects in UE4.12?
  4. Was the Third Person Project you tested Blueprint and the others C++?

Sorry for the late reply.

  1. I am using the launcher UE4. All of the templates
  2. I have tested are blueprints. I have’nt tested C++ recently.
  3. I am sure I do have VisualStudio 2015.
  4. Like I said in #2, everything I tested are blueprint projects.

Try these settings and let me know what you get:

  • Open a new Blueprint Advanced Vehicle project and include Starter Content
  • Run to File>Cook Content for Windows (Note any errors)
  • In Project Settings, select “Full rebuild, For Distribution, Include Debug Files” and set Staging Directory to a blank folder on your Desktop (your other settings are OK)
  • Package for Windows 64
  • If this generates a directory but fails to create an .exe file, post the debug files, if it gets to that point. If not, cut and paste the entire contents from the Output log in the Editor.

Hi kidarole1203,

Since we have not hear back from you in a few days, we are marking this thread “resolved” for tracking purposes… However, if you are still experiencing errors while building, please respond with the requested information above and we will continue to investigate.

Thanks,

Steve H.

I did each step and I actually got it to work! But why or how I don’t know. I tried cooking a bmuch bigger project that I have bbeen working on for a while and a day later it finally finished. I still had the same build error.

For a much larger project there are a number of variables that could cause the project to fail. We would have to have the output log in order to have an idea what’s causing the build to fail. As for building for Android in UE4.12 you have to set up Code Works, previously Android Works.

If you need help with the large project, please start a new post and post the entire new log files. (Even if the error seems the same, their could be additional info in the log for what is triggering the error.)