Build Error - metrics_discovery_helper_dx11.h not found

Erroring out with this not found only issue i’m having i went through and double checked my source folders and a fresh pull off of git to ensure i wasn’t just missing the file. Yes DX11 Is installed and running i’m running this same engine through unreal launcher but need a source build for certain plugins.

Version: 4.25.1

I had to modify D3D11RHI.Build.cs and insert this:

 //Tony; ugh, add the metrics discovery path, so debug builds actually find the bloody headers.
PublicSystemIncludePaths.Add(Target.UEThirdPartySourceDirectory + "IntelMetricsDiscovery/MetricsDiscoveryHelper/build/include/metrics_discovery/");

solved it for everything.

Hiya! I just had this same problem. Your solution helped me out a lot! Thank you.

After digging far deeper than I should’ve, I realized that (at least in my version)

was fine the way it was.
It wasn’t able to find

because the

module never added the path to its source QUOTE in the first place.
Then, using your solution, I noticed there was no

folder at all.

was actually path:

If you look in the build file you’ll see it *does *build a path, but it’s to a library directory. *Not *the source folder:

string IntelMetricsDiscoveryPath = Target.UEThirdPartySourceDirectory + "Intel/MetricsDiscovery/MetricsDiscoveryHelper/";
PublicSystemIncludePaths.Add(IntelMetricsDiscoveryPath + "build/include/metrics_discovery/");

**So, just under that last line, I added the following code and it worked perfectly afterwards:

PublicSystemIncludePaths.Add(IntelMetricsDiscoveryPath + "source/");


I’m not sure why or how this happened, but I hope it helps others who had the same problem we did.
Thanks again!

We ran into this issue as well. I was able to do a diff between a working build and a broken build. When I investigated this further, there’s a “build” folder which gets generated when you run “Setub.bat”. The “GitDependencies.exe” will scan your directory and create a manifest of missing files and directories, and then download them. For some reason, it seems to miss three source files in “/build/include”. The files already exist in the Intel third party folder, so to “fix” this, you really just need to get the files into the correct folders. You shouldn’t have to modify any code, and you should be able to delete the entire “build” folder and regenerate its contents by running “setup.bat”.

My fix was to edit the “Setup.bat” file and manually copy the missing files over to the right directories. You can copy/paste this into your “Setup.bat”, re-run setup.bat, and then it should work:

mkdir .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\build\include\
mkdir .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\build\include\metrics_discovery
copy .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\metrics-discovery\inc\common\instrumentation\api\metrics_discovery_api.h .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\build\include\metrics_discovery\
copy .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\source\metrics_discovery_helper.h .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\build\include\metrics_discovery\
copy .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\source\metrics_discovery_helper_dx11.h .\Engine\Source\ThirdParty\Intel\MetricsDiscovery\MetricsDiscoveryHelper\build\include\metrics_discovery\

1 Like