Build Crash

Well, I uninstalled/reinstalled. I’m now on version 4.12.2. Epic Games Launcher, Unreal Engine and SwarmAgent have access to all public and private networks. Everything still crashes though.

Well, I guess we tried. Thanks for taking the time to help, I appreciate it.

I’ve included two logs of a build crash of the FPS starter project on version 4.12.2., just in case it makes a difference.
[1]: 94250-myproject-backup-2016.06.11-07.16.42.log (92 KB)

I have one last thing we can try. Please go to support.toshiba.com. Once there, find your exact model and pull up the display drivers. You should see two drivers on the same date, which is 3-23-2016. One is 10.18.10.3412, the other is 10.18.15.4256. Install 10.18.15.4256. Let me know if this fixes the error.

Actually, when I was updating my drivers, 10.18.10.3412 was the only display update I could get to install. When I tried to install 10.18.15.4256 the computer said, ‘This computer does not meet the minimum requirements for installing this software.’

So, I downloaded several earlier releases of that update, including 10.18.15.4232, 10.18.10.4061, and of course, version 10.18.10.3412. Version 10.18.10.3412 is the only update that installed.

To be perfectly sure, I’ve just redownloaded everything and tried it again. Sure enough, only that one version installs.

I’m not exactly sure what the computer means when it says I don’t meet the minimum requirements, but I suspect It has to do with my version of Windows. If on the Toshiba support site in the Drivers & Updates section, you tick the words ‘Display’, ‘Driver’, and ‘Windows 8.1’ (my version of Windows) in the ‘Filter by’ list, update 10.18.15.4256 vanishes.

It might want Windows 7 or 10. I don’t own Windows 7 and I’m trying to avoid 10.

As far as I can tell my display drivers are up to date.

I suppose it’s worth mentioning that my version of Windows is virgin 8.1. I say that in case that’s why I don’t meet the ‘minimum requirements’ or in case UE4 requires a Windows update. I don’t update because I want to avoid those sneaky Win10 telemetry updates and that annoying little eyesore of an icon.

Hi SeaDog1948,

Try running the lighting build without the editor open. To do so, navigate to your engine filepath in windows explorer and go into \UE4\Epic Games\4.12\Engine\Binaries\Win64 and find UE4Editor.exe. Create a shortcut. RMB the shortcut and in the target line enter:

UE4Editor.exe “C:\MyProject\Project.uproject” -run=resavepackages -buildlighting -allowcommandletrendering -map=MapName

You will, of course, want to enter your own information into the generic sections. See if building without the editor open has a different effect or if it still crashes on you.

I’m probably making a mistake or two. When I launch the shortcut, a message appears that says, 'Failed to open descriptor file ‘C:/Users/John Doe/Documents/Unreal Projects/MyProject.uproject’

That project actually exists, so I must have entered something wrong in the UE4Editor shortcut’s target.

Here’s what I entered in the target:

“C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\John Doe\Documents\Unreal Projects\MyProject” -run=resavepackages -buildlighting -allowcommandletrendering -map=FirstPersonExampleMap

Rereading it just now, when I retyped the target here yesterday I forgot to add ‘.uproject’ to the end of ‘MyProject’. The actual shortcut’s target does at least have ‘.uproject’ in it.

I managed to find my mistake. As you probably guessed, I mistyped the projects target. Sorry for the delay.

Anyway, the program still crashes. I’ve uploaded a screenshot of it.

Hi SeaDog1948,

We stumbled upon one more thing you can try to see if we can resolve the error. The generic exception code you are seeing has been listed on Microsoft’s help forums here:

Try the steps listed to see if that helps. Additionally, as mentioned later the post, you can try using the Process Monitor To get more detailed information about specifically what is going on.

Portions of the Microsoft forum’s instructions aren’t working for me, so I might be a while trying to figure all of that out.

In the mean time, I ran Process Monitor during a build crash. I downloaded tutorials on how to troubleshoot a program with Procmon, but I don’t yet know how to interpret the data I’ve gathered.

What I did notice (again, I’m not quite sure what I’m looking for) is that at the end of SwarmAgent’s occurrences, it repeatedly tried to create and read files called things like ‘System.Data.dll’, ‘System.Windows.Forms.ni.dll’ and ‘System.Data.ni.dll’. I don’t know whether these occurrences happened before or after the build crash, because SwarmAgent kept occurring even after the crash. I’ve included a screenshot of all this.

Also, throughout the occurrences, Swarmagent was writing an AgentLog file, which I’ve included as an attachment.

Also, I’m including a Procmon text log of some of the events that occurred during the crash. I had to trim a lot from the top and bottom of the log because I have a 5MB filesize limit, but I hope there is something in there that is useful.

I’m also not sure how to pinpoint the exact moment the crash happened.

Also, I was pondering everything a few days ago. I’m now of the opinion that this program might not be installing correctly. For some reason, my computer usually needs programs to be installed with administrator permissions. I’ve had several programs run into serious problems because they were not installed as an administrator. One videogame in particular, wouldn’t run and claimed it didn’t even recognize my operating system until I reran the installation as an administrator. Perhaps drivers aren’t installed properly or registry entries are skipped.

It’s just a thought. I’ve run the Epic Games Launcher installer as an administrator and even given Epic Games Launcher administrator privileges to install Unreal Editor. Can I be sure Epic Games Launcher is installing Unreal correctly?

Hi SeaDog1948,

I have one last thing to try, which may help to determine if the editor is installing correctly. Try getting the github source build of the editor, which can be found here:

https://github.com/EpicGames/UnrealEngine

The instructions for setting up a github build can be found here:

Is there any way to associate the GitHub Account Name to my profile without giving out my home address?

Hey SeaDog1948-

Looking at the account page, the address fields are required when an update to the page is made. So the answer to your question would be “No, an address is required when you update the page with your GitHub account name.”

I don’t see the need to update the profile with that information in order to associate a GitHub account; and I think I’d prefer not to. Barring the GitHub Unreal Engine, is there anything else we could try?

If you think my case is a lost cause I can maybe come back to Unreal in a few years when I have a newer, less finicky computer. I don’t want to waste your time when there are other, perhaps more legitimate cases you could be working on.

After looking over the files you’ve submitted again, especially the DXDiag, it appears that the graphics card being used may not be strong enough to handle the stress of the building process. Seeings as you have already updated your drivers, the next best solution may be to upgrade the graphics card entirely. You can check the following page for details on recommended hardware to run the editor (A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums)

Cheers

Doug Wilson