Build Crash

The crash callstack should appear after the editor has crashed. Do you not get a window to report the error to Epic?

Not that I’m aware of, no. All I get is the dialog box that you see in the above screenshot. If I’ve disabled it somehow, I don’t see a means of enabling it via the Editor’s Preferences.

Unfortunately this happens with some errors. If you could try one more test it should help immensely in determining what is occurring. In a blank project, create a new, empty level. Once you do so. Add a single point light and a cube within the light’s radius. After doing so, press build. Do you see the crash occur? If so, can you post the crash logs for this specific crash here?

Yeah. it crashed. I get a Map Check error ‘Maps need lighting rebuilt’.

I just wanted to clarify, the Map Check error wasn’t the crash I was referring to above. The Map Check error occurred in addition to the actual crash of the program.

Try running through this troubleshooting guide to see if the error is one of these common issues. If not, please let me know and we can continue digging to find the source of your error:

I read through the Swarm Agent guide and followed as best I could. Most of the errors mentioned didn’t seem to be related to my problem, as far as I can tell.

I can’t open SwarmAgent.exe when I click on it, if that’s relevant.

I did manage to make a minor breakthrough though, I think. While checking error reports in the Windows Action Center, I managed to discover a series of errors related to Unreal Engine. Every time the program crashed, Windows claims this was to blame:


Source
Unreal Engine

Summary
Stopped working

Date
‎6/‎1/‎2016 12:26 PM

Status
Not reported

Description
Faulting Application Path: C:\Program Files (x86)\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: UE4Editor.exe
Application Version: 4.10.4.0
Application Timestamp: 56c62e24
Fault Module Name: igdusc64.dll
Fault Module Version: 10.18.10.3412
Fault Module Timestamp: 52e04797
Exception Code: c0000005
Exception Offset: 0000000000176be2
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 1033
Additional Information 1: abdb
Additional Information 2: abdb0113f68b90f09eaf6285721d6a1a
Additional Information 3: 7164
Additional Information 4: 7164485e788e28d873397563061a1645

Files that help describe the problem
AppCompat.txt
WERInternalMetadata.xml
memory.hdmp
triagedump.dmp
WERGenerationLog.txt

Description
Faulting application name: UE4Editor.exe, version: 4.10.4.0, time stamp: 0x56c62e24
Faulting module name: igdusc64.dll, version: 10.18.10.3412, time stamp: 0x52e04797
Exception code: 0xc0000005
Fault offset: 0x0000000000176be2
Faulting process id: 0xc34
Faulting application start time: 0x01d1bc192c72f72f
Faulting application path: C:\Program Files (x86)\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe
Faulting module path: C:\WINDOWS\SYSTEM32\igdusc64.dll
Report Id: 0cc6dc93-2813-11e6-8278-f406693c0e01
Faulting package full name:
Faulting package-relative application ID:

I have around ten error reports from Unreal, and not a single one ever appeared in a window when Unreal Engine would stop working, which is strange.

Anyway, I hope this information helps somehow.

Try updating your GPU drivers and see if that helps.

I think I’m updated now. There’s always the possibility I’m not, because I had to wade through dozens of available updates to find the ones that matched my machine. I’m about 90% sure I’m updated though.

Anyway, whatever I did didn’t work. Unreal Engine still crashes.

Hi SeaDog1948,

Please go here and download the drivers present. Additionally, please ensure you are definitely on the latest drivers. Let me know if this fixes the error.

Actually, I’ve already tried to install that update. With that one, along with several others, I had a mess of a time. I kept getting an error message, ‘The driver being installed is not validated for this computer.’

I just now redownloaded it and tried it again to be sure, and it doesn’t work.

The next thing I did, was download the ‘Intel Driver Update Utility.’ It told me there are no graphics updates for my computer because my drivers are custom. So I went to the Toshiba support website and looked up the recommended updates for my specific computer, downloaded and installed them.

The latest one was from late 2015. As far as I can tell, I’m as up to date as I’ll ever be.

So, am I out of luck here?

The model of pc you have, does it come with an r9 card? The only thing we really haven’t tried other than completely uninstalling and reinstalling the engine is to check that the integrated graphics card is not being used instead of the r9.

I have an Intel HD Graphics 4600, so I don’t think so. How do I check if Unreal Engine is using my Intel graphics card?

Try turning off your firewall before running the build again. I was looking through your logs again and found this line:

LogSwarmInterface:Error: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:8008

It looks like your computer is preventing SwarmAgent from running, which could be the cause of the crash. Turning it off before the build will allow SwarmAgent to run. If this works, SwarmAgent will need to be whitelisted in your firewall settings to be able to be utilized. Please try this and let me know if it works.

I don’t typically allow just any program through the firewall, but last week on a hunch I allowed SwarmAgent through the firewall just to make sure. It hasn’t fixed things.

Sometime soon I was going to try a complete uninstall/reinstall and see if that makes a difference. I’m still positive, because there was a brief period of time where everything did work. Things built to 100%.

Any chance sometime in the future UE4 will see even broader compatibility expanses to grant mercy to odd computers like mine? I have three indie game ideas I would love to bring to life in UE4.

Unfortunately at present I do not have an answer to that question. The reason I suggest moving swarmagent and the editor into the exceptions for your firewall and anti-virus programs is that we have seen in the past that they throw a false positive and will often be prevented from correctly working. There have been no instances to date of someone receiving a virus or malware from the launcher/editor/swarmagent.

Well, I uninstalled/reinstalled. I’m now on version 4.12.2. Epic Games Launcher, Unreal Engine and SwarmAgent have access to all public and private networks. Everything still crashes though.

Well, I guess we tried. Thanks for taking the time to help, I appreciate it.

I’ve included two logs of a build crash of the FPS starter project on version 4.12.2., just in case it makes a difference.
[1]: 94250-myproject-backup-2016.06.11-07.16.42.log (92 KB)

I have one last thing we can try. Please go to support.toshiba.com. Once there, find your exact model and pull up the display drivers. You should see two drivers on the same date, which is 3-23-2016. One is 10.18.10.3412, the other is 10.18.15.4256. Install 10.18.15.4256. Let me know if this fixes the error.

Actually, when I was updating my drivers, 10.18.10.3412 was the only display update I could get to install. When I tried to install 10.18.15.4256 the computer said, ‘This computer does not meet the minimum requirements for installing this software.’

So, I downloaded several earlier releases of that update, including 10.18.15.4232, 10.18.10.4061, and of course, version 10.18.10.3412. Version 10.18.10.3412 is the only update that installed.

To be perfectly sure, I’ve just redownloaded everything and tried it again. Sure enough, only that one version installs.

I’m not exactly sure what the computer means when it says I don’t meet the minimum requirements, but I suspect It has to do with my version of Windows. If on the Toshiba support site in the Drivers & Updates section, you tick the words ‘Display’, ‘Driver’, and ‘Windows 8.1’ (my version of Windows) in the ‘Filter by’ list, update 10.18.15.4256 vanishes.

It might want Windows 7 or 10. I don’t own Windows 7 and I’m trying to avoid 10.

As far as I can tell my display drivers are up to date.

I suppose it’s worth mentioning that my version of Windows is virgin 8.1. I say that in case that’s why I don’t meet the ‘minimum requirements’ or in case UE4 requires a Windows update. I don’t update because I want to avoid those sneaky Win10 telemetry updates and that annoying little eyesore of an icon.