Bug With Overlaps events and physics simulation

I 've noticed a problem in the last hotfix 4.9.1 (everythings work well before update) who break all my pickup blueprint. It seems that begin/end overlaps are wrong and repeated if the trigger is attached to a static mesh with physics simulation enabled, there’s no problems if physics disabled

HI Nicobass,

Could you try this in a new project to see if the issue still occurs? If it does, post that test project here for us to investigate further.

the problem is still there…

Thank you for the test project. I have created JIRA UE-17865 and our developers will be investigating the issue further. We will post here with updates as we have them.

As a workaround, disabling ‘Auto Weld’ from the Trigger will fix the issue.

Cheers,

TJ

hey any news on UE-17865?

by the way, disabled ‘auto weld’ from the trigger fix only the begin overlap when overlaping the trigger, but then the end overlap happen if the mesh move

Yep, it looks like somewhere between 4.9 and 4.9.1, the issue was reopened. I’ll post here again when I see that another fix come through. Thanks!

Is this still a thing?.. Cause this is exactly my Problem atm I guess.

Ok I fixed it by adding a SceneNode between Mesh and TriggerVolume.

The problem is still occuring, it can be fixed by setting collision on child to queryOnly (no Physics).