Bug with Event in different GameMode

I had a bug which i haven’t been able to reproduce yet.
I fixed it for now but i still wanted to post it since it seemed odd.

(I use the blueprint system)
In my setup i have 3 levels (Main menu, Lobby, Ingame)
where Lobby and Ingame have their respective GameMode (selected in GameModeOverride in the world settings)

Today when i loaded up my project and started it in standalone (I have started it in standalone multiple times before the problem occured in the same session) i changed from the Main Menu level to
the Lobby level. During that, code fired from the IngameGameMode connected to the “Event OnSwapPlayerControllers” (it was just a print string).
It also caused all my casts from the owning player (from the lobby menu) to my custom lobbyPlayerController to fail.

After i found the code in the IngameGameMode i disconnected it from the “Event OnSwapControllers”, ran the game (which worked fine again) and reconnected the code to try and reproduce it but it still worked like it was suppossed to.

Hello ,

I’ll try to reproduce the issue and post an update.

As said it was a bit weird as the issue happened all of a sudden without me changing all too much within the project.
Even after i deleted the code which was causing the issue, I reset the blueprint to its state when the issue was occuring but was unable to reproduce it.

I’ll post the screenshot of the problem code in my update later.

Hello Pp_p,

I was unable to reproduce this issue on our end. I have a couple of questions that will help me narrow down the issue you are experiencing.

  1. Are you able to reproduce this issue in a new project?
  2. If so, could you provide a detailed list of steps so I can reproduce your issue on our end?
  3. Could you provide screenshots of your game mode’s blueprints?
  4. does this issue occur outside of standalone game?


Created a new project from scratch and was not able to reproduce it.
I also played around with my current project but nothing changed.

If there is anything else i can do feel free to say.

Here is the screenshot of the blueprints in the IngameGameMode.

I am still unable to reproduce your issue. To investigate your issue further I will need to see your project directly. You can message me privately on the forums here:

Hello II-Pyo,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.