Bug with enabling spline mesh collision at runtime?

Hey guys,

I’ve looked around on the answer hub and I’ve found some references about previous instances of issues with spline mesh collisions.

I am creating my spline meshes at runtime, and I want to be able to change their collision response to the player pawn from ‘Overlap’ to ‘Block’ after an event triggered by the player.

The collisions work perfectly fine when the spline meshes are constructed (i.e. added with ‘Add Spline Mesh Component’) with collision enabled, with or without a custom channel but I suppose that’s the whole issue.

Trying to change collision response/enable it at runtime yields no results.
I can see the collision boxes with debug drawing, and they respond to trace tests, but they seem to refuse to change collision responses at runtime.

Here is my setup, would appreciate any insight!

Are you sure you are working in 4.12, because the bug you are talking about should be fixed in 4.12.

Very certain, but I did import this project over from 4.11.
Would that make a difference?

Okay, that is very strange, I’m not with back at my office till Tuesday, so can’t check it myself atm. Let’s hope someone Epic can check it for you :).

Hopefully yes!
Thanks anyway for letting me know that something might be wrong, was out of options and ideas. =)


Wanted to keep this alive so that some Epic Staff might be able to see this.

Would really appreciate some insight into this from some Epic staff as I am not sure where to turn at this point.