Download

Bug with BP based ENums

Hey everyone!

I’ve been working a mod to the player pawn over the past couple weeks and ran into an issue with ENums via blueprints. I think it’s a bit of a cosmetic thing, but it’s kind of nagging and annoying. It seems that no matter what names I get the enumerators in enums, in blueprint (at least the player pawn), the variable for the enum doesn’t carry the names over properly. I’ve attached images to show the problem.

I’ve not worked with enums much in the past, so it’s completely possible I’m missing something, but when I replicate the creation of the enum in a 4.15.0 project, it was reading fine and displaying the names perfectly fine. Is this a bug, or am I missing something?

Thanks!

borkedEnum_3.JPGborkedEnum_2.JPG9436fb1615bfe0dfa87741a981816880f8f50f8d.jpeg

Are you defining this Enum in BP or in code?

This will likely be resolved when saving the related enum structure?

BP asset

Saving, reset, etc has not resolved it.

Okay maybe this is related to the RoboCall UE client version, since you appear to replicate it. However, it also might be simply resolved when re-creating the enum select node, a common issue when copy-pasting stuff.

Tried this too, deleted and rebuilt the ENum, didn’t really copy/paste anything. Same deal. Even created alternate test BP enum assets for verification, and have the same results.