[Bug] User viewport information residuum


I met a strange artifact in my current project that I don’t see in the sample projects. I have no idea from what this visual residuum come neither as since when. I only noticed it today. It’s very hard to see and I managed to see it because of my dark blue fog inside of one of my scene.

My user information (Rocket build and my name) are visually duplicated and overlapped with a very small opacity in the middle of the viewport. This visual residuum also happen if I launch my project as a game (without the editor). It happen on all my maps.

It’s not a post-process thing as when I go out of my post-process/lightmass volumes the artifact stays. My only guess at the moment could be the fact that I deleted all the config files of my project (all my window/editor preferences) in the past and letting Rocket regenerating them made this.

Build info :

  • Version : 1711197
  • Install path : C:\Rocket

Specs :

  • OS : Windows 7 x64
  • RAM : 16 GB
  • Graphic Card : GTX 660 (drivers 314.21)


I have that too. I thought it was intentional

Well, if the sentence weren’t overlapping each other maybe. :slight_smile:

Hi Fabrice,

This is a security measure that will be removed in a future beta.

Michael Noland

Hey Fabrice,

I’ve tried what you suggested and it doesn’t seem to be happening for me. Any other information that might help us reproduce this?

Best Regards,


I have really no idea from what/where this came from sorry. :frowning:
I could send my project, but it already weighs 560 mb. Would you like I put in on the FTP ?

No that shouldn’t be necessary. What were the specific names of the project files you deleted in the config folder or editor config files and did you do anything after like compile or add something major to the level? Also does this occur in any new level or project now or is just specific to this?

Best Regards,


For the config files : all. Simply all of them in my project (from my config folder to the other ini files in the saved folder).

When I removed these file is was during the crash of the build (solved by disabling the Internet access of Rocket). I continuer working on my project then after letting Rocket regenerating the ini files. Editing blueprints, levels materials and so on. I can’t be specific because I did too much things since this moment.

This is happening inside a new level based of the Default template (with the sphere, the torus and the box) and also with an empty level.

Hey Fabrice,

Does this happen in a new project? If it does try uninstalling and reinstalling Rocket. Otherwise think you could provide the config files for the project?

Best Regards,


I just tested and yes, this is happening in a fresh and new project. I have attached the config files from my both projects (current in use + the new one). Both projects were generated from the Third Person template (c++).

link text