[Bug] "Use Flat Base for Floor Checks" Vibrates

At check the “Use Flat Base for Floor Checks” in CharacterMovement over MyCharacter blueprint, generated at create new fps project with c++, if create large ground with a box(bsp/gsc) 700m~ at center~ the map/camera vibrates some times.

If make a wall and add a curb of 2units, and jump to it the player down, but if use the default collision without “Use Flat Base for Floor Checks” the player walk over the curb.

Hi Hgdavidy,

Thanks for the feedback. I was able to reproduce your first issue and I will be looking into it further. I’ll update here with my results.

As for the second issue, maybe I am misunderstanding your results but the ‘Flat Base for Floor Checks’ should allow the player to walk onto and off of curbs. It simulates the bottom of the capsule as flat instead of round. This keeps the player from sliding off of ledges due to the bottom of the capsule being curved.

Thanks, TJ

The camera hitch not only happens in a code project but a blueprint one as well. I have submitted this for our developers to look into.

Thanks, TJ

Ok, the second is the next test:
Create 2 generic cubes, put one in the top of the other, now put the grid at 1 and make a curb/stair of 2 units in the grid(moving the top cube), now jump on it with the default character, and you can walk over this. Now enable the ‘Flat Base for Floor Checks’, jump on it and you go to fall.

I’m sorry if I am misunderstanding, but I just to clarify the repro steps:

  • Create 2 BSP boxes
  • Stack one on top of the other
  • Create stairs high enough to jump on top
  • Enable “Use Flat Base for Floor Checks”
  • Climb up the stairs and jump onto the boxes

I’m unsure what you mean by, “now put the grid at 1 and make a curb/stair of 2 units in the grid(moving the top cube)”, I assume it’s step 3.

Make this:
And test with on/off “Use Flat Base for Floor Checks”, a view what happens.
If is enabled you fall, if is disabled you don’t fall.

I was able to reproduce what you are talking about, thank you for the screenshot. This is actually working as intended. The ‘Use Flat Base for Floor Checks’ doesn’t just simulate the bottom as flat but it actually calculates the collision with the floor more accurately than the capsule does by itself. So when you have a ledge that small it doesn’t allow the player to stand on it.

In other old games, if the player collision is a box, you can’t call, because the sides are squared and no rounded, but size this “simulate” isn’t a real box solution, this need add more primitives options than a capsule. Ok thanks.