[BUG] Unreal 4.9 Bug has been replicated in other projects.

I have found a large bug but I found the workaround too.

Scene Render 2d Component based Blueprints cant be placed in world,and this is important, UNLESS you have Bloom settings enabled on your directional light.

The Light Rendering breaks the editor and causes a major crash if Bloom settings are unchecked and you place a Scene Render 2D Component, or a blueprint containg on, in the world.

As 4.9 has been out for a while don’t expect a hotfix for it, but do this simple thing before placing it in the world and it won’t be an issue.