BUG Unreal 4.11 | Multiplayer Does Not Work Correctly When Tick Interval Is Not 0

I recently updated to 4.11 but I’m pretty sure this problem is present 4.10 but when I tried to play a multiplayer on separate computers over LAN either the client or server would crash when the client joins the session. After weeks of trying to fix this problem I was browsing through a crash log and found an error saying something like FTickFunction. I ended up fixing this problem by setting the tick interval in each blueprint back to 0. I originally had it set to 0.016 so that the tick would fire about 60 times per second. This problem did not happen when I was playing in PIE or hosting and joining a session on the same computer the problem only happened when I put the game onto a second computer on the same router and we tried to play a LAN session.

This is not really a engine breaking problem but it has increased my CPU time noticeably.

Sorry I would provide the crash files but I no longer have them I can’t seem to find them anymore.

I find this issue very interesting, I hope Epic gets back to you on this!

Hi !!!

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide any code and/or screen shots of blueprints that may be involved with this issue?

Here is a image of the player blueprint. If I were to set the tick interval at the right to a higher number at least higher than 0.016 then then the client no longer be able to connect to a session without crashing.

Again if you package the game up, host and then join the session on the same computer it will work just fine. You need to join the session from a separate computer on the same network as you. Generally the game will crash on wither the client or the server but sometimes neither person crashes and the client is not able to execute any code in the blueprints for instance the event tick and begin play will never get called or triggered whatever you want to call it.

Hello ,

Thank you for the additional information. However, could you please answer the other two questions that were asked in my previous comment. known if and how this can be reproduced in a clean project will help narrow down what issue it is that you are experiencing.

I have been trying but I can not reproduce this problem in a clean project. I still have no idea why this would happen in my main project though.

Hello ,

Could you provide a simplified version of your project that reproduces this issue along with a set of steps to reproduce this issue in your project?

Hello ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.