[Bug] UE doesn't pack all but one level while packaging

I have:

  • a single player game on UE 4.16, made on Windows 8.1;
  • some maps;
  • a default map to be run by editor and standalone game (main menu), which leads to other levels;
  • everything working in PIE and while testing as a standalone app;
  • crashes and errors after packaging;
  • [dump files and logs][1].

The game shows only main menu and then either restarts instead of opening another level, or crashes. Logs show that

[2017.06.29-14.30.24:560][189]LogPackageName: SearchForPackageOnDisk took   0.095s, but failed to resolve L_00_Intro.umap.

What I’ve tried to solve this problem:

  • renaming maps 'cause they were all starting with _underscore and UE4.16 didn’t like such names;

  • re-saving, building all the levels;

  • refreshing nodes in any blueprints working with level navigation;

  • adding levels to cook explicitly in project configs, like this (after that I began getting crashes):

    … lalala …

My levels are organized like this:

And I load levels in main menu like this:

And the incoming data seems to be correct:

I’ve updated to 4.16.2 and nothing changed.
Also I tried moving all content to an empty project, and it didn’t help too.

Somewhat connected to this issue: https://answers.unrealengine.com/questions/402341/index.html

For those who will face this issue, go to your Project Settings → Project → Packaging page. In Packaging section expand additional params with an arrow. Check ‘Cook everything in the project content folder’. All the maps will be bundled then.

It is regression though

I still feel it is a bug; more exactly, a regression. Everything worked in 4.14, there was no need to mess with settings. All my UI responsible to map navigation has never changed from previous project (it was just migrated to a new one). Levels were put in a special folder too.

Anyway, this is not an intuitive behaviour ‘cause we can’t reference maps via blueprints (we can just put maps’ names), and therefore, imho, maps should be bundled by default.