[Bug] Translucent Blend mode gives incorrect rendering


I was trying to setup some reflexion (like presented here : http://wiki.polycount.com/FaceTopology?action=AttachFile&do=get&target=mathis_eye_construction.jpg ) for my character in Rocket, however I’m unable to setup a correct blending with the Translucent blend mode. The specularity is removed and the preview (material / instance) of the shader emit light while the emissive channel is disabled (even when set manually at zero).

At the same, I was wondering if it was possible to make a shader totally invisible (diffuse invisible) but with the specularity visible as I would like to simulate the cornea on an eye ?

Build info :

  • Version : 1711197
  • Install path : C:\Rocket

Specs :

  • OS : Windows 7 x64
  • RAM : 16 GB
  • Graphic Card : GTX 660 (drivers 314.21)

Lit mode :

Translucent mode :

Hi Fabrice,

Unfortunately the editor does not support translucent materials with specularity at this release. It is being worked on currently and will be featured in a later build.

You can achieve the desired effect through a CubeMap in your material. To do this, import a HDRI texture to the editor; this is show the “reflection” image. Create a Texture Sample Parameter Cube in the material and then add your HDRI texture as the node’s texture. Create a Vector Transform and plug that into the ParamCube’s UV. Create a Reflection Vector and plug that into the Vector Transform. After this is set up, attach the ParamCube to BaseColor.

You will end up with a result like this:

I hope that this has helped to resolve the issue. If there is anything else that you need assistance with, please do not hesitate to ask.

Thank you,


Thanks !

To generate this cubemap I have to do it outside of unreal I believe as there is not current way to generate texture cubes ?

They can be created in the editor, but those will contain no image information. So yes, you would have to import a .hdr file into the editor. That will automatically be created as a cubemap texture.