BUG? Tilt control not working on ASUS ZenPadZ8

I have tilt control set up and working perfectly fine on my iphone, but it does not work properly on my ASUS ZenPadZ8. I hooked up a printstring to my tilt event and found that it is jumping from in the Z axis from -3 to 3 with no inbetween. Maybe this is a BUG?


Can you please tell me which Android Version your device is on?

Thank you!

Thanks for responding. Android 6.0.1, This is a huge annoyance since this is the only android im testing my game on. How I am testing it:

I checked this out on a using 6.0.1 and verified that tilt control is working. I have looked up the specs for the Asus Zenpad Z8 that you’re on and verified that we do not have a device that has the exact same specs as what your device does.

I went ahead and tested it on an Asus Zenfone 2 and verified that the tilt control is working.

Therefore, I’m going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer
  • Go here: C:\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Here is the log, I am using the rolling ball template with the test node set up above. Thanks for responding

[link text][1]

101145-log.txt (63.4 KB)

what I ment was the problem is that it would jump between a certain number and a similar number but negative. Notice in the log how it jumps from a positive to negative same number (like 2.8 to -2.8) with no in between movement close to zero, my game requires precise movement. It has nothing to do with the string being pushed to the side.

Your whole log shows the tilt working on your device. Is it just not showing up on the device? Or do you think that it’s pushed off to the side, due to the size of the device screen?

Feel free to upload a sample project of your own, where you’re verifying the issue on your phone, and I can compare it to mine, if you’d like.


I misunderstood your issue just a bit, thanks for explaining further.

When the phone is:

  • Laying flat, it seems to stay around 3.19
  • Pick up, laid on its side flat, it’ll stay around 0.4
  • Tilted to the left, it’ll stay around 2.55
  • Tilted to the right, it’ll stay around -2.55
  • Tilted away from me, it’ll stay around 3.19

It does depend on how steady my hand is, where I’m leaning it. If I tilt towards my right hand, the numbers are negative and when tilting towards my left hand, they’re positive and change based on which way i’m tilting the device the most.

Are you noticing on your phone that it’s randomly jumping around? I’m noticing that mine are quite steady when watching the numbers that are being printed. However, I am slowly moving the device. I noticed that if you move it too quickly, it doesn’t print all of the numbers.

when im holding the device in my hand, looking directly at the screen, even the slightest tilt will jump it from 2.5 to negative 2.5 and vice versa. My Iphone is nothing like this and is able to get a smooth transition like when I tilt from one side to the other the string prints something like (1, 0.75 0.5 0.25 0 -0.25 -0.5 -0.75 -1) for iphone, but for the pad it jumps (2.5 -2.5) with NO transition. Is this the case for only the pad and not for all androids, cause if all androids are like then the game is broken or i am going to have to add a touch option (that would break the game concept). Another thing I dont understand is how a game like temple run would be able to get that accurate tilt movement on my zenpad, is this something to do with UE4.
Still though thanks for the response, I was worried it was something on my end like a defective zenpad.

hey I have tried your blueprint I have the same issue :frowning: im trying to make a game with ball to tilt the screen but its not working at all :confused: i’m testing it on Xperia Z 3

This is actually resolved in 4.13 but there is a rendering issue in 4.13 with launching onto certain Android devices. Therefore, you might get a grey screen that isn’t rendering properly if you test on your device. My for example gets this issue. We’re working on a fix for this rendering issue as well.

UE-6135 is the tilt axis issue and UE-34053 is the rendering glitch on Android in 4.13.

Thank you!

Thank you for the information, I would like to know exactly when a stable version of unreal engine 4.13 or a newer version of 4.12 that fixes the bug will come out, i wanted to release my game now, that i have worked on for months, but now I can not launch, and downgrading to another to 4.11 is not an option because of the plugins I am using. Help please, i want to release this as soon as possible. Its not just me, MartinDiavolo is also having the problem, and all my beta testers first feedback to me is that the character is veering off to the side and the game is “broken”.

Please respond back if this issue isn’t fixed with the release of 4.13. It may be in an upcoming preview, but I can’t guarantee that at this time.

Thank you! :slight_smile: