Download

Bug: Starter content incomplete

Hi guys,
I just started with Unreal Engine 4.8.2 yesterday. Two things:

  1. Is there a bug tracker for Unreal Engine?
  2. I found a bug when creating a new project in the editor; see below.

After creating a new project, note that the Starter Content folder contains just the Architecture subfolder, with just one item in it:
unreal-engine.bug.starter-content.png
After reloading (close/open) the new project, everything is there as it should be:
unreal-engine.bug.starter-content-after-project-reload.png
Cheers,
Lennart

Hi TardonHD,

If you find something you think may be a bug, it is best to post it on the AnswerHub. We are able to track issues better there while we investigate them.

I made an attempt to reproduce the issue that you described, but was unable to see the same results. Everything within the StarterContent folder appeared the first time the project opened after it was created. Are you using the binary version of the Engine that is installed by the Launcher, or did you build the Engine from source code? Does this only happen when creating a new project with one specific template, or does it happen regardless of which template you use? Would you be able to create a new project so that this issue occurs, then close the project and upload the log file from the Saved folder (don’t re-open the project)? Could you also provide your dxdiag information?

Thanks,
Tim

Hi Tim,
Thanks for a swift reply, and for the pointer to AnswerHub which I’ll use next time.
I’m using the binary version for Windows that’s installed by the launcher. I’ve tried to reproduce the issue with several templates (Third Person, First Person, Flying), same result in all cases.
Attaching the log file from the Saved folder. I had to rename the extension from .log to .txt because otherwise this forum wouldn’t accept it.
I’ve had a glance at the log file, and it seems all the folders and items are created on project creation. But they’re not displayed in the editor, as you can see from my screenshots.
Lennart

Hi Lennart,

I made a few new Blueprint projects using various templates in 4.8.2 and was not able to see the same results that you described. In my cases, the Starter Content folder was always fully populated when the project finished opening after it was created. If you could check something else for me, that would be great. Create another new project with Starter Content and after the Editor has opened, select the Starter Content folder and then do a search in the assets window for “cube”. It may come back blank, but I am hoping it will look something like this.

StarterContentCube.PNG

It would also be great if we could get your dxdiag information in order to rule out anything hardware related.

Tim

Thank you for you reply, Tim
I have one question: Where can I find the dxdiag information?

Cheers,
Lennart

I did what you said, made a new project with Starter Content, and searched for ‘cube’. Here is the result:
2c87d8ca55eb1492b0f4e8ba573d7827704632ce.png

Cheers,
Lennart

Just run the “dxdiag” tool from command line. It will aggregate all relevant information and allows to save it to a diskfile.

Another thing you could check here: Go in the launcher and choose “verify” from the launcher options. Maybe your installation has gone stray in some way…

Thank you, KVogler and Tim, for your replies!
I’ll be away for the next week. I’ll reply on return.

Cheers,
Lennart

Sorry for letting you wait so long, but I re-installed the Unreal Engine (the new version 4.8.3) but the Starter Content is still incomplete in new projects.

I will soon send you the dxdiag information.

Cheers,
Lennart