[BUG]Sound Mix modifier not working properly

Hi, I think I have encountered a bug. I had it inside my project and could isolate it, so I am sure it is not something messed up with my objects/blueprints.

I have a Sound Class for my music files, and a Sound Mix, that sets the Music class to volume 0.0 (name ist SM_NoMuiscMix)

When I call ClearSoundModifiers and then push my modifier e.g. when clicking a button, the following behaviour occurs:

Clicking once mutes the music like expected. On the next click the music starts again, what should not happen. On the third click it is muted again. And this goes on, switching off and on.

It is not expected, I expect that on every click the music stays disabled, because every click I push the mix again.

I have tested this in code and blueprint both (UGameplayStatics in code), and with more SoundMixes, and it occurs everytime.

Hi birdfreeyahoo,

I was able to reproduce this on my end and have entered a bug report, UE-13010 to be assessed by the development staff.

Hello birdfreeyahoo,

Thank you for the post. I have been working with the developers to attempt to narrow down where your issue is originating from. If you are able would you mind taking a screenshot of your blueprint as well as any changes that you have made to the sound class setting as well as the sound mix settings? I would like to make sure that I set up the reproduction as close to the original as possible.\

Thanks in advance,

Benjamin Hyder

Hi, I came across this bug in my own project today (4.7.6 download), any news on when this is going to be fixed?

Unfortunately this bug is still under assessment. I do not have a timeframe of when it will be fixed. Do you have a screenshot of the sound class and sound mix settings? Additionally any screenshot of the blueprint setup you are using may be helpful in finding the root cause of this error.

ok here is it:

Classes and mixes:

Calling code:

Hi everyone,

I have great news! I was testing this today and cannot reproduce as of 4.8 preview 4. It looks like as long as you use both push and pop state to remove the previous modifier with a pop state immediately after setting the new modifier with a push state, the modifiers work as expected.

Hey Folks,

not sure if this is important for you and why it is like this. i had also the problem, that i had no reaction on my sound mix modifer ingame. Everything worked, execpt of the blueprint node “Set Sound Mix Class Override”.

the problem was, i put it into the event int of my gameinstance and i had no reaction.
after i put the “Set Sound Mix Class Override” into an other event it worked well. Just for people who running maybe into the same issue.

I am running it right now from my Widget and it doesn’t work… what type of Blueprint did you put it into?