Download

[Bug] Some Files Not Showing in Editor

Hi all,

I’ve posted the issue on the answers.unreal section, but wanted to post here as well in case the community knows of this issue:

https://answers.unrealengine.com/questions/260764/marketplace-purchase-not-all-files-show-up-in-edit.html#comment-260764-form

I downloaded DayNight Cycle from the marketplace and dropped it into Indigenous to see how it looked and functioned, but about 40% of the assets didn’t show up in the editor. No errors or warnings, they just…aren’t visible inside UE4. I checked the File Explorer and all the files are actually there. Every file is marked as a .uasset.

I then tried opening in a new 4.8.2 project, and all the files are visible. So clearly it has something to do with the Indigenous project specifically. I tried migrating the files from that new project, and everything migrated successfully but the files still weren’t visible in UE4. I also had a team member try the same things to ensure it wasn’t my workspace, and he has the same issue.

Here’s a visual of what I mean: http://i.imgur.com/xwdGOBY.png

Anyone have suggestions on how to fix this?

thats kinda odd O.o where is it?!
Was there an error message at loading?

Its in the correct spot - you can see the files in the right folders if you’re using file explorer (windows desktop). There’s no errors or warnings upon load. I can even drop one of the blueprints that I do have access to into a map and it plays fine with no error or warning. It’s as if they were somehow marked as hidden. The Maps and Sprites folders are completely empty to me in UE4 (though I see theres files in there via file explorer), but the folders still show up in UE4. They’re just empty.

I just replied to your answerhub, but I’ll post it here too.

If the project you are working in was built in 4.7 it won’t read some of the assets that were created in 4.8. I was able to recreate the issue by inserting the files into a couple projects built each in the different engine versions. (see image)

No guarantee that this will work, but you might try converting your project to 4.8 and then injecting the Day/Night Cycle assets again. Let me know if that works. If not we’ll see if we can find another solution for you.

Mike V

I found a solution to this issue.
*
"Alright, this has been resolved. The issue was that this package makes use of Paper2D sprites, and I had the Paper2D plugin disabled when I imported the assets. It wasn’t showing any file that touched the sprites since it didn’t know how to handle those file types (even though they were .uassets, UE4 couldn’t recognize the format without the Paper2D plugin enabled).

I assumed this might be the problem 2 days ago and turned on Paper2D, but for some reason it didn’t fix the issue at the time. However I just tried enabling Paper2D again and it worked. Everything shows up per normal."*

The dialogue can be found here: Marketplace Purchase - Not All Files Show Up in Editor - UE4 AnswerHub