[Bug] SETRES is not working correctly for windowed mode in beta6

Update: see below for pic and Repro

Dear Friends at Epic,

I am using Beta6 Voyager and have never had this issue before:

I feel a bit silly for having to ask this,

but did something happen to the console command SETRES ?

I’ve been using it almost every play session through all the early betas

but now in beta 6 if I type into the console window:

SETRES 1920x1080


SETRES 1920x1080f


SETRES 640x480w

nothing happens at all !

Is this normal?


I am running my game as independent instance from a batch file, the editor is not loaded at all.

Here is that commandline / batch file:

"C:\Program Files\Rocket\Engine\Binaries\Win64\RocketEditor.exe" E:\RocketVictory\VictoryGame\VictoryGame.uproject -game  -ResX=1280 -ResY=960 -WinX=0 -WinY=0 -log




I ran my game strictly from the .uasset

and typed in SETRES 640x480f

and it worked!

then I wanted to revert

so I typed

SETRES 1920x1080f

and nothing happened…

I tried SETRES 1920x1080w

and it worked!


To switch resolutions, depending on whether the console is WINDOWED or FULL you sometimes have to switch WINDOWED or FULL just to get the resolution change to register.


load a game, choose a resolution via SETRES, in FULLSCREEN

then try to change to a diff resolution still in full screen

you might have the change not take place

then switch to windowed and it the change should occur.

Can also try this in reverse, going from one windowed res to another windowed res and see if that change occurs, or if you have to go fullscreen to get the change to occur




Hey Rama,

Thanks for the report! We were able to reproduce this issue internally and have filed a defect report. Hopefully we’ll have the issue resolved for the next Rocket Beta :slight_smile:



woohoo Thanks Steve!

If you post your answer as an answer I can give you credit for it and close this thread :slight_smile: