Download

[bug] scalling bone won't scale collision

When you sale down bone in skel mesh that have physical asset you will see that collision from this bone won’t be scaled.

What I’m trying to do is to destroy body parts. And it’s funny when you blow up head you can still shoot at it :wink:

Answerhub post: [BUG]Why after scaling down bone collision is still there? - UE4 AnswerHub

There is a node Hide Bone - which is scaling it down and there’s ENUM for collision update. It isn’t implemented in C++.

Normal behaviour should be:

  • When scaling bone down in animation blueprint or using Hide Bone node collision from phys asset should be scaled as well. (as in UDK)

Repro:

  • You can use Shooter Game Example phys asset for this.
  • Scale down some bone in animation blueprint,
  • See that collisions from this bone are still there,

Any feedback on this?

I’m running into this issue and need to hit test against a scaled bone.

Currently the hit tests against scaled bones do not work, when I perform a hit test on a scaled bone the physics asset is not scaled and performs a miss.

When I turn on debug drawing for the collisions, show collisions, it is drawn correctly but the hit tests fail anyways.

Has anyone figured out how to solve this? Thanks. I’m using engine version 4.27.