[BUG REPORT] Asset Reference resets to none

Hey Guys! After the release of 4.10 last week I converted my project from 4.9.2 to 4.10. And recently I came across a bug which resets some of the asset reference inside the class blueprint.

I’ve a character blueprint whose AnimBP asset reference keep setting itself to “None”. This is also happening with a blueprint containing a 3D widget where the widget class ref sets itself to “None”.

This occurs whenever I restart the editor.

Nobody experienced it yet?

Hi ,

  • Does this occur in only one project or does it happen in any project?
  • Do you have any circular references in these assets?
  • What steps can I take to reproduce this on my end?
  • Where are these assets being referenced?
  • In the widget specifically, do you have any other widgets referenced within the 3D widget or is it all in one widget?

Hi ,

  • As per now, I haven’t tried it with
    any other project.

  • I might have some circular reference for the widget, but the
    AnimBP doesn’t have any.

  • Steps to reproduce:

  • Create a child class from existing character bp.

  • Assign mesh and animBP for the mesh component.

  • Compile.

  • Restart Editor.

  • The AnimBP asset is referenced in the character mesh component and the widget is referenced as a widget class inside an actor with a 3d widget component.

  • It is all in one widget.

It all worked pretty good in 4.9.2, but started causing issues as I moved my project over to 4.10


Can you send me a sample project this is occurring in? I attempted to reproduce this on my end but thus far have been unsuccessful.

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.