[BUG] Re-import static mesh issues

So I’ve created a scene in 3ds Max of a tree model with 2 LODs, Vertex Paint and two Collision Objects.
When importing the mesh the first time, I checked all of the boxes in advanced import options; textures, materials, lods etc. The problem is I realized I accidentally made a mistake with the collision objects intersecting so I adjusted them and selected re-import on the static mesh. Sadly this re-imported everything and made a duplicate of all of my textures and materials and re-assigned these new materials to the mesh instead of my tweaked ones.

Is there no way to enable some sort of intelligent re-importing where it only re-imports the parts of the scene that have changed. Or even the option to ONLY re-import certain parts of the scene like the LODs or Collision?



I had a similar issue with some settings related with UCX collision meshes and lightmap uv channels. It seems the settings you have when you first import a model will remain after you reimport. So now, I’m used the change check the model settings before reimporting again. In your case would be unchecking whatever option enables material importing in the model editor, and after that, reimport.

It would be cool if that could be more automatic though.


Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.