[BUG] PlayerStateClass set to none = crash

You can set GameMode.PlayerStateClass to “None” in blueprint editor (Defaults). This result in editor silently crashing without any error when entering play/simulate mode.

Hello Xarn,

Regarding this issue, are you setting this state through C++ or through the editor itself? Any chance you can provide reproducible steps so that we may investigate it?



Yes this is in Editor (compiled from source, or downloaded)
Steps to reproduce:

  1. Start Editor and create new blank project

  2. Create new Class Blueprint inheriting from GameMode

  3. Open that blueprint in editor and compile + save without any changes

  4. In project settings, Maps & Modes, change Default GameMode to that blueprint.

  5. Hit play, and see everything is ok.

  6. Open blueprint in editor again, and in Defaults tab change Player State class to None, compile and save

  7. Hit play. Editor silently crashes

Also I, just noticed that downloadable version of the editor actually wants to send crash report, but callstack seems to be empty. Anyway I will send that crash report and point to this question in it.


Thank you for providing the repro steps, I now see the issue and have entered a bug in our database for tracking.

Great work, please continue to point out any issues you come across so that we can log them for our team to review.