[Bug] Play modes giving different results

I have created a blueprint which tracks the distance between the matinee camera and a target, updating every time the distance changes.

When playing in viewport, it all works flawlessly. However, when running it in a standalone game, or movie mode, the blueprint stops working. Due to the play modes not giving the same result, I believe this must be a bug.

Hi Vect,

Do you have your gamemode, controller, etc. set up in both world settings and project settings? Additionally, how do you have your matinee set up?

Hi Vect,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this bug, please comment with the requested information. Thank you!

Apologies for the delayed reply. The setup of the matinee is just a basic path-based matinee that starts on game startup in cinematic mode using blueprints. As far as I can tell, the gamemode, controller, HUD etc are setup correctly.

I have tried several ways in blueprints to track the matinee camera’s distance from the AOI, but each way still results in the matinee working in the viewport but not in the standalone editor. I’ve attached an image of the basic setup for the matinee. If you think it’d be useful to see the HUD as well, please let me know.

Hi Vect,

If you could show us the HUD real quick that would potentially be very beneficial. Additionally, I know you said they should be, but if you could check one more time to be absolutely certain that the world settings and the project settings are both set to the same when it comes to game mode, controller, HUD, and pawn. The reason is that generally when there is a discrepancy between viewport and standalone game, this is where it resides. I would like to rule out that possibility now so we can focus on what else could be causing the error. Thank you!

No problem - I’ve checked to make sure and the world and project settings are the same; they have the same game mode, same HUD class etc. Attached is how the HUD is setup. It’s near enough the same HUD as found in the HUD example, just with an added distance based alpha for the text and the camera rather than the player as the object to measure the distance to. Also I’ll note that I have a day/night cycle running in blueprints that works the same in viewport and standalone play modes.

Thanks for any advice/assistance with this you can give.

Hi Vect,

One more question for now, what version of the editor are you currently using?

It was made in 4.3, but is now running in 4.4.

Hi Vect,

So it is working and no longer having this error?

Hi ,

Sorry, I meant that I am using version 4.4, having originally started the project in 4.3 The problem is apparent in both versions. If there is anything more I can do to assist please let me know.

Hi Vect,

If you are comfortable with it, I would be happy to take a look at your project and see what might be occurring. You can post a link to a trusted FTP server such as dropbox here and I will grab the file to see what is going on. Thank you!

I’d be happy to do that however as the project uses corporate data there would need to be a way of me providing a password or some other limitation/verification. Would it be possible to email you a link to the project?

I have been looking at this and I am admittedly quite lost as to what could be happening. The two different gametypes and HUD’s are effectively the same with some minor variation. Yet I cannot seem to get the actual gamemode to work as you have described. What I would recommend is trying to create a copy of the working blueprints and renaming them, see if the copied HUD and gamemode work.