[BUG] Particle > mesh orientation not working in 4.5 , 4.6, 4.7

So I was looking at the mesh-based particles I made a long time ago and found out they all where messed up in 4.5, 4.6 and 4.7 but did work in 4.0, 4.1, 4.2, 4.3 (did not test 4.4).

In Cascade:
I use the Mesh Data > Orientation to rotate the meshes to the position I need them.
In 4.7 this is located at Mesh Data > Orientation > Roll Pitch Yaw Range.

In 4.0, 4.1, 4.2 and 4.3 it looks and acts like this:
(Ignore the particle color, just look at its rotation)

In 4.5, 4.6, 4.7 however it acts like this… Or better yet… it doesnt do anything at all.

I did some settings with alternative distribution options that are now available:
And as you can see, if both values are different some rotation does appear to happen.

And even stranger, if both values are set to 90 it behaves even weirder.

My guess is (and personally think) it should work like the example in 4.2.
So whats happening here?
I consider it a bug.

I have also tried to rotate the meshes in the “Required” node, and “Init Mesh Rotation” but to no avail.
I have tried both without the init mesh rotation and init mesh rotation rate as well, this does not influence the test. (afaik)

Creating individual meshes for each of the 100+ particles which are basically the same but rotated is something I rather not do :stuck_out_tongue:

I hope this gets fixed soon!

I am really sorry for the inconvenience. I was just fighting with this bug myself. I have mentioned it to our engineers and will make sure a proper bug is filed.

One work around that I have employed is to set the emitter to velocity align and set the velocity to a very low value in the direction you wish it to face with drag applied.

Sorry for the difficulty, this bug can make things tough when using mesh emitters in world space.

Hello HomeRye, Tom Shannon suggested the same thing (using the same workaround atm) but I rather not do this.
Currently I can permit to wait for a fix, that is… if it wont take months to update it.

Hopefully it gets solved in a decent time period :slight_smile:
thanks for submitting a bug report!