[BUG] Multiple visual glitches

I have been experiencing two recent Unreal Engine visual glitches. The first is when I highlight an object in the editor the whole object is selected in a way so I cannot see what the object looks like. I don’t know much more about what’s going on. Example:

      The second glitch happens to be these strange visual glitches:

      The glitch includes these black lines flashing all about. I know it's not a problem with my project as I reinstalled the engine and created a third person template project without any further content and the glitch continues lives on.    

** If anyone could help that would be great. Thank you!**

Hello Jackenstein,

I was unable to reproduce this issue on our end. I have a couple of questions that will help me narrow down your issue.

  1. Can you reproduce this issue in a new project?
  2. If so, could you provide a detailed list of steps so I can reproduce your issue on our end?
  3. Have you altered any of the editor settings prior to this issue occurring?

Thanks!

For a test, I just created the third person project and the flashing begins right away although I have noticed that the flashing only occurs on objects that I’m not staring directly at. The strange object selection issue also lives on in the new project.

I’m not sure what has led up to these strange effects although I have removed the Substance plugin and the MODO material importer from the engine multiple times with projects needing the plugins and for the projects needing the plugin I went into the uproject file and removed the plugin. That could be the mistake although I have completely removed all UE4 and Epic Games launcher files from my system. After removing all of those files I reinstalled and reset my PRAM and SMC. I then created a new project and the issue is still there.

If you would like any type of log files I would be fine with handing them over.
Thanks for the help!

Could you post your DxDiag? and have your updated any drivers recently?

Just to clear somethings, I’m having this problem on my OSX version of UE4 and the version I have on my Windows machine runs the project just fine.
In OSX I’m not completely sure if this is what you are looking for although here’s some of the hardware information:

131151-hardware.png

what is your graphics card in your machine?

I’m using this graphics card:

131541-card.png

      Edit: I just noticed something, these effects only take place in 4.15.1 as I just created a project in 4.14.3 and none of these effects take place. The issue is my project utilizes the new engine and its features.

Hello Jackenstien,

Does this issue occur for all 4.15.1 projects you create, or is it only affecting a specific project?

All 4.15.1 projects.

Update: Just did a factory reset and reinstalled UE4. After making a brand new project the glitches are still on all 4.15.1 projects.
Video example of the glitch: Video of glitch

Hello,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks

This issue has been resolved for me in UE4 1.17, Sorry for not following up.