[Bug?]Launch on android device need to restart editor?

Hi Epic,

I’m using 4.8.3, and not sure this is an known issue.

The thing is, sometimes, I have to restart editor to make sure the modified BP scripts is worked when Launch on android device.

This can’t be reproduced from a blank project, sorry for that.

Have you tried to rename/remove the src and APK folders and then relaunch it from the editor?
Well, it would require a restart of the editor anyways …

You could create a new game mode, switch to it and Launch, then switch back to your project’s game mode.

I just found that, it worked!

Hey XiuXiu,

I know that you’ve said this can’t be replicated on a blank project, are you able to replicate it on a template? Do you have reproduction steps you can provide to us, so that we can verify the bug? Does this happen in 4.9 Preview 4? Did you obtain the editor through GitHub or the Epic Games Launcher? What version of Android are you on, which Android device are you pushing to?

Looking forward to hearing back from you, thanks!

Hey XiuXiu,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thanks!