Bug in Removing Keys Frame in UE5

Following this Creating an Aim Offset | Unreal Engine Documentation

In UE5 EA. Removing key frames will always maintain keyframe 0-1. Makes it impossible creating aim offsets. I had to use UE4 and make the aim offsets and reimport into my UE5 project.


I have had the same problem. Is it a bug in UE5? Are there any ways that we can work around it, without going to 4.26?

1 Like

I have worked out a fix for it. Just go to the frame that you want for the aim offset. Hit the record button and record the frame. (make sure you know where its saving.) Then open the recording and just remove the frames that you don’t need, and there you go you have an aim offset. If It doesn’t work let me know


Another option is to select the frame you want to copy from your aim space animation and click ‘Create Asset/Create Animation/Current Pose’ and click ‘OK’. This worked for me. I hope you find this helpful.


this is the easiest

Confirming that the two suggestions above work perfectly!