Bug in Enum can not switch to 1 var

I have a shooter which has a enum of weapons for the player. So I don’t know what happened to my enum, but it worked before. There are 4 different weapons pistol, machine gun, shotgun, rocket launcher. This did work before but now I can’t switch to my machine gun.

so I bypassed the branch and set it just to the set, and it would still not work. If I changed it to shotgun or rocket launcher and It worked. I even set the default of the enum to machine gun, and nothing the enum will literally not switch to machine gun but will to the others. I have no idea as what to do for fixing this. I’m going to attempt adding/removing from the enum too see if that may fix what has happened.

Hello shotty46290,

I was not able to reproduce your issue on our end. I have a couple of questions that will help me narrow down your issue.

  1. Did you change any properties of the enum before the machine gun stopped working with it?
  2. Can you access the machine gun from another blueprint?

I saw in your comment that you planned to delete the machine gun and simply add it back in again to test that as a fix. It will help my investigation of your issue to know the results of that test.

Thank you!

I didn’t delete was kind of scared too. Also sorry for the late response. What I did was added another and just called it machinegun2 and it worked fine. So I haven’t touched the enum else wise.