[Bug in 4.9] {fixed for 4.10} Can't add a keyframe (Y or Z axis) to vector track inside a timeline


I cannot add a keyframe in the Y or Z axis of vector track inside a timeline. It does work for the X axis only. When you lock the X axis and try to add a keyframe to either Y or Z “shift click” does nothing and “right click” only shows “add key to X”

It appears to be a bug in 4.9.1 as doing the same thing in 4.8.3 does work (and did work in earlier versions too).

Has anyone else experienced this? it should be fairly easy to replicate to confirm its a bug (or it’s just me). i.e. go to level blueprint, create a timeline, add a vector track and then try and add a keyframe on just the Y or Z axis.

i am running 4.9.1-2689999, normal build. Please let me know if you need any further info.

Edit: This was fixed in 4.10

Hi General_Robbo,

I attempted to reproduce this but I couldn’t get your results. I can create key frames for all three vector points.

Can you try it in a new project and let me know if it still happens for you?

Hi TJ,

Thanks for the reply. I have created a new project under 4.9.1 and i still have the same trouble. I even tried few times; once as a blank project and a couple using the templates. I did the same with 4.8.3 but do not encounter this issue.

If you are unable to replicate it sounds like a problem at my end but i’m not sure how unless my version of the engine is corrupted?. I will re download 4.9.1 and see if that helps.

Thanks, I’ll let you know how i go.

I’m on 4.9.1 and i have the exact same issue.

Hi General,

Have you had any luck with this?

no luck. tried the reinstall and new project etc and still come up with the same issue. I am downloading 4.9.2 now to see if the issue goes away.

thanks Olle3000 for the info and glad to hear its not just me as it may make it easier to locate and fix the issue now. Are you able to add anything to my description of the issue?

Not really, my issue seems to be the exact same as yours, i can only edit one axis of a vector timeline

but i can choose any of the three vectors x,y,z

Did the 4.9.2 update fix the issue for you?

unfortunately no.

To clarify;

  1. In a blueprint (i.e. level editor of component) i create a timeline
  2. I add a vector track
  3. I can add a keyframe but it only adds it to X
  4. If you lock X and try to add a keyframe to Y and Z (or just one of them by locking the other too) it does not work. The shift click does nothing and the right click only shows “X” as an option (although greyed out as it is locked).

Am I missing something here? because i should be able to do this. By the way i have tried it under a number of circumstances that i know i have done before and it still doesn’t work.

Could you all post a screen shot or a short video that shows exactly what you are seeing?

Hey guys. I’m having the same issue, though I’m new to Unreal so I assumed I just didn’t know how to add keyframes.

I’m on a Mac and I always seem to run into dumb errors like this with every piece of software I use, so I figured that was the problem here as well.

Here’s a screenshot of the right click context menu that only allows adding a point to X, regardless of having all 3 axis unlocked and visible:


And here’s a screenshot of still only having access to the X axis even though only the Z axis is unlocked and visible.


I’m really hoping this is fixed soon. I’m considering downloading UE on my Windows machine so I can see if it’s still a problem there.

OS X Yosemite, 10.10.5 (14F27) - in case that helps.
Also, here’s the Unreal version jazz: 4.9.2-2707645+++

Thanks for the post Azaii. This exactly what i am seeing.

I am running Windows 7.

Okay, I see what you mean now. Thank you for the additional info.

While adding the first key, all tracks are stacked on top of each other and the top most track is X. Which is why only ‘Add key to X’ shows up.

We have this issue logged as JIRA UE-18554 in our system. I’ll update that report to reflect that multiple people are also reporting this.

As a workaround, you can use the Shift+Left-Mouse Click method. Just lock the track/tracks that you don’t want to add keys to and Shift+Left-Mouse Click to add keys.



Unfortunately that doesn’t work either, at least for me :frowning:

Hi Olle3000,

I see that you are on 4.9.1 but what operating system are you using?

Also, try updating to the 4.9.2 hotfix if possible. Nothing in that hotfix should have effected this but it’s best to test it in the latest build.

I have the same issue, and found a temporary solution:

1º In the time line add a new Vector Track and Hide and Lock X and Y curves

2º On the Z (blue) curve, simply spam Left Click while holding Left Shift

I have no clue why this works for me, but I could make a few keys and then simply adjust the values. I also have found that spamming it on the second and third “separation boxes” have more results. Also, don’t spam on the same spot, but rather move the mouse left and right along the curve.

I’m currently using U4 4.9.2. I have this issue in all my projects, even in new ones. And if you were wondering, yes I found this solution out of desperation and spam-clicking my frustration out.

Hope this helps,

Just an update, shift clicking doesn’t work for me either, though I’ve yet to try the ultra-professional spam click method trademarked by . Ha ha.

Note: I also just upgraded to the new Mac OS El Capitan. I doubt that’ll change anything but we’ll find out in a few minutes.

Update: Shift clicking multiple times around the line for Y and Z does actually seem to work. After I get a few points on, I can pretty much shift click anywhere to add more. Strange.

I have to add at least one key to each track and then separate them. Once separated, I can manipulate whichever axis I want and set the extraneous keys to zero. It’s ugly, but it works.