Bug in 4.8/4.8.1 "Always Create Physics State"

I imported a skeletal-mesh and created a blueprint with it. If I enable the option “Always Create Physics State” the editor crashes. I tried the same thing in 4.6.1 and it worked flawlessly.

Hi Merlin96 -

I have tried with a few different skeletal meshes and have not been able to reproduce any crash in 4.8.0 or 4.8.1. Can you share the particular skeletal mesh that is causing this issue for you, and is it causing the issue in a blank project with no starter content?

Thank You

Eric Ketchum

Hi Eric,

thanks for your answer. I just tested it again myself in a new blank Blueprint project and I found out that in the generated Physics Asset, the option “Physics Type” need to be set to “Simulated”. If I now create a blueprint with the skeletal-mesh and set the option “Always Create Physics State” to true the Editor crashes.

Hi merlin96 -

That was it. I was able to reproduce it internally and have entered a bug report as UE-17742. As we investigate a solution I will keep you informed here.

Thank You -

Eric Ketchum